Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » general approach for "conflicting dependency" problem on updating plugins(same problem with 4 different plugins)
general approach for "conflicting dependency" problem on updating plugins [message #896615] Thu, 19 July 2012 03:24 Go to next message
moritz du is currently offline moritz du
Messages: 98
Registered: February 2010
Member
i have a similar problem with 4 different plugins. i can't update them because of "Cannot complete the install because of a conflicting dependency."
Is there a general approach for this kind of problems?

As an example the first of them:

"Eclipse IDE for Java EE Deveopers"
Error:
Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse IDE for Java EE Developers 1.5.0.20120614-1633 (epp.package.jee 1.5.0.20120614-1633)
Software currently installed: TPTP Tracing and Profiling Tools Project 4.4.2.v201101261720-7H7C47XbM_K5E9OJKVWb_hSVH4 (org.eclipse.tptp.trace.runtime.feature.group 4.4.2.v201101261720-7H7C47XbM_K5E9OJKVWb_hSVH4)
Only one of the following can be installed at once:
Eclipse Workbench User Guide 3.6.1.r361_v20100825-0800 (org.eclipse.platform.doc.user 3.6.1.r361_v20100825-0800)
Eclipse Workbench User Guide 3.7.1.r372_v20111202 (org.eclipse.platform.doc.user 3.7.1.r372_v20111202)
Eclipse Workbench User Guide 3.7.0.v20110601-0800 (org.eclipse.platform.doc.user 3.7.0.v20110601-0800)
Eclipse Workbench User Guide 3.6.0.v20100608 (org.eclipse.platform.doc.user 3.6.0.v20100608)
Eclipse Workbench User Guide 3.6.2.r362_v20101117-0800 (org.eclipse.platform.doc.user 3.6.2.r362_v20101117-0800)
Eclipse Workbench User Guide 4.2.0.v20120606-135340 (org.eclipse.platform.doc.user 4.2.0.v20120606-135340)
...

The other problematic plugins are:
m2e, m2e - slf4j, uml2 extender sdk
Re: general approach for "conflicting dependency" problem on updating plugins [message #977529 is a reply to message #896615] Fri, 09 November 2012 05:56 Go to previous message
Shawn Tan is currently offline Shawn Tan
Messages: 1
Registered: November 2012
Junior Member
Yes, I am also having such a problem!

My error message is as below:

Quote:
Cannot complete the install because of a conflicting dependency.
Software being installed: TPTP Tracing and Profiling Tools Project 4.4.2.v201101261720-7H7C47XbM_K5E9OJKVWb_hSVH4 (org.eclipse.tptp.trace.runtime.feature.group 4.4.2.v201101261720-7H7C47XbM_K5E9OJKVWb_hSVH4)
Software currently installed: Eclipse IDE for Java EE Developers 1.5.1.20121004-1506 (epp.package.jee 1.5.1.20121004-1506)
Only one of the following can be installed at once:
Eclipse Workbench User Guide 4.2.0.v20120829-072800 (org.eclipse.platform.doc.user 4.2.0.v20120829-072800)
Eclipse Workbench User Guide 3.7.1.r372_v20111202 (org.eclipse.platform.doc.user 3.7.1.r372_v20111202)
Eclipse Workbench User Guide 3.7.0.v20110601-0800 (org.eclipse.platform.doc.user 3.7.0.v20110601-0800)
Eclipse Workbench User Guide 4.2.0.v20120606-135340 (org.eclipse.platform.doc.user 4.2.0.v20120606-135340)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.5.1.20121004-1506 (epp.package.jee 1.5.1.20121004-1506)
To: org.eclipse.epp.package.jee.feature.feature.group [1.5.1.20121004-1506]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.5.1.20121004-1506 (org.eclipse.epp.package.jee.feature.feature.group 1.5.1.20121004-1506)
To: org.eclipse.platform.feature.group [4.2.1.v20120814-120134-9JF7BHVGFyMveli1uX6aTH0q-eAap6PAgOP5mO]
Cannot satisfy dependency:
From: Eclipse Platform 4.2.1.v20120814-120134-9JF7BHVGFyMveli1uX6aTH0q-eAap6PAgOP5mO (org.eclipse.platform.feature.group 4.2.1.v20120814-120134-9JF7BHVGFyMveli1uX6aTH0q-eAap6PAgOP5mO)
To: org.eclipse.platform.doc.user [4.2.0.v20120829-072800]
Cannot satisfy dependency:
From: TPTP Trace ARM Doc User 4.4.1.v201009092123 (org.eclipse.tptp.trace.arm.doc.user 4.4.1.v201009092123)
To: bundle org.eclipse.platform.doc.user [3.6.0,4.0.0)
Cannot satisfy dependency:
From: Instrument ARM UI Feature 4.4.1.v201009092123-797708s73533H3I6A56 (org.eclipse.tptp.trace.arm.ui.feature.group 4.4.1.v201009092123-797708s73533H3I6A56)
To: org.eclipse.tptp.trace.arm.doc.user [4.4.1.v201009092123]
Cannot satisfy dependency:
From: TPTP Tracing and Profiling Tools Project 4.4.2.v201101261720-7H7C47XbM_K5E9OJKVWb_hSVH4 (org.eclipse.tptp.trace.runtime.feature.group 4.4.2.v201101261720-7H7C47XbM_K5E9OJKVWb_hSVH4)
To: org.eclipse.tptp.trace.arm.ui.feature.group [4.4.1.v201009092123-797708s73533H3I6A56]
Previous Topic:Editor extensions
Next Topic:Update site project: invalid license agreement?
Goto Forum:
  


Current Time: Fri Aug 29 04:15:26 EDT 2014

Powered by FUDForum. Page generated in 0.01615 seconds