Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Xpand] Running MWE workflow with Xpand generator outside eclipse?
[Xpand] Running MWE workflow with Xpand generator outside eclipse? [message #896499] Wed, 18 July 2012 14:37 Go to next message
Alan DW is currently offline Alan DWFriend
Messages: 108
Registered: March 2012
Senior Member
Hello everyone,

I'm developing a plain Java standalone application. It is not an Eclipse RCP application and not an Eclipse plugin.

I have a MWE workflow file (including an XPand generator) which I would like to use in that application. However, when I attempt to run the MWE workflow in my application (using org.eclipse.emf.mwe.core.WorkflowRunner), it prints its typical header message to console and then *freezes* and does nothing more. No error, no exception, no message - nothing which would be any help in problem diagnostics.

Do I need to do anything particular when running a workflow outside eclipse compared to what needs to be done from within an Eclipse-plugin? The very same workflow used to run fine when started from inside an eclipse plugin...


Greets,


Alan

[Updated on: Wed, 18 July 2012 14:39]

Report message to a moderator

Re: [Xpand] Running MWE workflow with Xpand generator outside eclipse? [message #896525 is a reply to message #896499] Wed, 18 July 2012 16:48 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 6494
Registered: July 2009
Senior Member
No this should perfectly work. Can you share something reproduce able?

--
Need training, onsite consulting or any other kind of help for Xtext?
Go visit http://xtext.itemis.com or send a mail to xtext at itemis dot de
Re: [Xpand] Running MWE workflow with Xpand generator outside eclipse? [message #896670 is a reply to message #896499] Thu, 19 July 2012 10:55 Go to previous messageGo to next message
Alan DW is currently offline Alan DWFriend
Messages: 108
Registered: March 2012
Senior Member
Hello,

thank you for your response, Christian.
Yesterday, to keep things simple, I did not tell the whole story here. I'm actually not developing a standalone Java program, but a plugin for MagicDraw (which is, in turn, a standalone Java application).

Your post reinforced my belief that the workflow engine should work even outside eclipse. So I did some quick testing on a *real* standalone Java program (with the same workflow) and I got some errors about classes not being found, which did not show up for some reason in the MagicDraw plugin. So, I've added the required JAR files to my classpath, and it worked out (there are some smaller issues but I think I can fix them).

When I added the same libraries to the MagicDraw plugin, it finally stopped freezing and showed me some exception message that I can deal with - anything is better than no message at all.


Thank you for your help, I will try to fix the remaining errors, maybe I'll post here if I encounter more problems along the way.


Greets,


Alan
Re: [Xpand] Running MWE workflow with Xpand generator outside eclipse? [message #896671 is a reply to message #896499] Thu, 19 July 2012 10:56 Go to previous message
Alan DW is currently offline Alan DWFriend
Messages: 108
Registered: March 2012
Senior Member
EDIT: Sorry, I accidentally added the same message twice!

[Updated on: Thu, 19 July 2012 10:57]

Report message to a moderator

Previous Topic:[XPAND]Transform XML to TEXT
Next Topic:XPand2 extension problem
Goto Forum:
  


Current Time: Tue Nov 25 23:34:36 GMT 2014

Powered by FUDForum. Page generated in 0.01579 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software