Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Update site problem
Update site problem [message #895827] Mon, 16 July 2012 04:38 Go to next message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 319
Registered: July 2009
Senior Member
I have troubles updating to the nightly builds. Eclipse wants
to update to 2.1.0.201207081523, but that is not the newest.

I am behind a corporate firewall/proxy, so I guess that is related
somehow. I only have the problem with the EGit plugin, not others.

Is there anything a user can do inside Eclipse?
Re: Update site problem [message #896166 is a reply to message #895827] Tue, 17 July 2012 09:24 Go to previous messageGo to next message
Manuel Doninger is currently offline Manuel Doninger
Messages: 119
Registered: October 2010
Senior Member
We had the same problem, because the proxy cached the outdated metadata and Eclipse tried to resolve old plugins. As a user you can only try many times, until it fetches the correct versions. On the other hand (and that was our solution), our admins disabled the proxy caching for the whole download.eclipse.org domain, so that problem doesn't exist any more.
This problem also exists only with nightly update sites, where the metadata continuously changes. With regular update sites, you have always the same metadata and so caching is not a problem.

[Updated on: Tue, 17 July 2012 09:25]

Report message to a moderator

Re: Update site problem [message #896288 is a reply to message #896166] Tue, 17 July 2012 17:17 Go to previous message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 319
Registered: July 2009
Senior Member
Manuel Doninger skrev 2012-07-17 15.24:
> We had the same problem, because the proxy cached the outdated metadata
> and Eclipse tried to resolve old plugins. As a user you can only try
> many times, until it fetches the correct versions. On the other hand
> (and that was our solution), our admins disabled the proxy caching for
> the whole download.eclipse.org domain, so that problem doesn't exist any
> more.

Ok, maybe I'll can ask our support if it happens again. For some reason
the update worked today. I was wondering if it could have anything to do
with how the update site was configured.

-- robin
Previous Topic:Installation EGit
Next Topic:s3 git repository
Goto Forum:
  


Current Time: Sat Aug 23 01:40:10 EDT 2014

Powered by FUDForum. Page generated in 0.06751 seconds