Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Not Able to Run Servlet in eclispe(It is throwing an exception that ports are already used by other application.)
icon5.gif  Not Able to Run Servlet in eclispe [message #895794] Mon, 16 July 2012 05:24 Go to next message
Jagdeep Gupta is currently offline Jagdeep Gupta
Messages: 8
Registered: July 2012
Junior Member
HI,
I have my projects in two directory :
d:/Jagdeep and d:/Ganesh/Java_ex
in later directory when I run the servlet´╗┐ with help of eclipse it run and show output but in d:/jagdeep directory it always throw an error that tomcat can not be started as the port 8080,8005,8009 is being used by other application.
Can anyone help me to resolve this?
Re: Not Able to Run Servlet in eclispe [message #895850 is a reply to message #895794] Mon, 16 July 2012 10:10 Go to previous messageGo to next message
Shyam Prakash is currently offline Shyam Prakash
Messages: 11
Registered: June 2012
Junior Member
just check if your port is already occupied. one way to do is try accessing via your browser localhost:8080 or 8005 or 8009. If you still get this error, go and change the port numbers in your tomcat/conf/server.xml and try once again.

~Shyam
Re: Not Able to Run Servlet in eclispe [message #895921 is a reply to message #895794] Mon, 16 July 2012 13:50 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 7/15/2012 11:24 PM, Jagdeep Gupta wrote:
> HI,
> I have my projects in two directory :
> d:/Jagdeep and d:/Ganesh/Java_ex
> in later directory when I run the servlet´╗┐ with help of eclipse it run
> and show output but in d:/jagdeep directory it always throw an error
> that tomcat can not be started as the port 8080,8005,8009 is being used
> by other application.
> Can anyone help me to resolve this?

If you're running Tomcat from within Eclipse as you seem to say here,
you modify the port settings by double-clicking this Tomcat in the
Servers view of the Eclipse workbench.
Re: Not Able to Run Servlet in eclispe [message #896028 is a reply to message #895921] Tue, 17 July 2012 01:57 Go to previous messageGo to next message
Jagdeep Gupta is currently offline Jagdeep Gupta
Messages: 8
Registered: July 2012
Junior Member
Thanks for replying,
Yes I am using Tomcat through eclipse.
But at the same time I am able to run in the another folder why it is so?
and If I have to change the port number then what new port number should I give?
Re: Not Able to Run Servlet in eclispe [message #896182 is a reply to message #896028] Tue, 17 July 2012 14:00 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 7/16/2012 7:57 PM, Jagdeep Gupta wrote:
> Thanks for replying,
> Yes I am using Tomcat through eclipse.
> But at the same time I am able to run in the another folder why it is so?
> and If I have to change the port number then what new port number should
> I give?

You may use just about any port number. Right now, I'm using 8005/8000/8009.
Re: Not Able to Run Servlet in eclispe [message #897211 is a reply to message #896182] Mon, 23 July 2012 08:33 Go to previous message
Jagdeep Gupta is currently offline Jagdeep Gupta
Messages: 8
Registered: July 2012
Junior Member
Thanks for replying, Now it is working fine after changing the port number.
Previous Topic:ClassNotFoundException when running JUnit tests
Next Topic:add org.eclipse.core.resources.natures to extension as a plugin extension
Goto Forum:
  


Current Time: Thu Oct 23 01:44:02 GMT 2014

Powered by FUDForum. Page generated in 0.07113 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software