Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Cannot update Subversive on Eclipse 3.7
icon4.gif  Cannot update Subversive on Eclipse 3.7 [message #895743] Sun, 15 July 2012 15:54 Go to next message
Juris Sudmalis is currently offline Juris SudmalisFriend
Messages: 9
Registered: March 2011
Junior Member
Here's the deal:
clean setup of Eclipse 3.7, no settings changed, no plugins installed, just vmargs changed for better performance.
Installed Subversive from Help > Install new software, restarted Eclipse, so far so good.
Went to Preferences > Install/Update > Available software sites, found "http://download.eclipse.org/technology/subversive/0.7/update-site/" (added when Subversive gets installed), enabled it.
Went to Help > Check for updates, Eclipse says "updates available" and pops up the update window.
Available updates:
Quote:
Subversive SVN JDT Ignore Extensions (Optional) (Incubation) 0.7.9.I20111119-1700
Subversive SVN Team Provider (Incubation) 0.7.9.I20120520-1700

Click finish, get this:
Quote:
An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.team.svn.core,0.7.9.I20120520-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.help,0.7.9.I20120520-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.resource.ignore.rules.jdt,0.7.9.I20111119-1700
No repository found containing: osgi.bundle,org.eclipse.team.svn.ui,0.7.9.I20120520-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn,0.7.9.I20120520-1700
No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.resource.ignore.rules.jdt,0.7.9.I20111119-1700


"Contact all update sites during install to find required software" is checked.
Worked just fine a few days ago.
Wat do?
Re: Cannot update Subversive on Eclipse 3.7 [message #895972 is a reply to message #895743] Mon, 16 July 2012 17:26 Go to previous messageGo to next message
Robert Emmons is currently offline Robert EmmonsFriend
Messages: 28
Registered: July 2009
Junior Member
I had the same problem as you, and found a fix. I don't know if this will work for you, but here is what happened.

I tried to install the Subversive plug in through Eclipse Help, but it did not work. I don't know why. Maybe the site was down. I dowloaded the zip file, and installed Subversive from a folder on my hard drive.

Later, when I tried to update, I got the same types of error messages as you are seeing. Eventually, I realized that there were 2 Subversive servers listed in my "Window/Preferences/Install/Update/AvailableSoftwareSites". One was on my hard drive. The other was "http://download.eclipse.org/technology/subversive/0.7/update-site/". I unchecked the one on my hard drive, and checked the correct remote update site. That fixed my problem.

Good luck.
Re: Cannot update Subversive on Eclipse 3.7 [message #896263 is a reply to message #895972] Tue, 17 July 2012 19:15 Go to previous message
Juris Sudmalis is currently offline Juris SudmalisFriend
Messages: 9
Registered: March 2011
Junior Member
Hmm, well, when I searched for the update site in "Available update sites", there was only one with "subversive" in it...
But anyway, I set up 4.2 now, hopefully it won't be as slow as my setup at work; PDT is damn slow.
Previous Topic:Updating Change Sets for SVN Workspace - ERROR
Next Topic:How to provide SVN credentials via Subversive plugin
Goto Forum:
  


Current Time: Mon Nov 24 14:23:24 GMT 2014

Powered by FUDForum. Page generated in 0.02393 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software