Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Have functional but non-updatable platform(Update system unusable.)
Have functional but non-updatable platform [message #895670] Sat, 14 July 2012 14:17 Go to next message
Steve Cohen is currently offline Steve Cohen
Messages: 43
Registered: July 2009
Member
I would like to install a new plugin - the new logback-beagle plugin to my Eclipse Indigo system. I cannot do it due to supposed dependency conflicts. I next try to to update Eclipse itself and it won't let that continue because of dependency conflicts.

How did my system get into such a mess? It is functional now. Why did it let me install stuff in the past that would not be updatable in the future? And how, aside from starting from scratch can I get out of this mess? I thought all these fancy new tools were to make the upgrade process easier?

My configuration is attached.

I cannot get past the following error messages:

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse IDE for Java EE Developers 1.5.0.20120614-1633 (epp.package.jee 1.5.0.20120614-1633)
Software currently installed: AspectJ Development Tools 2.1.3.e37x-20110628-1900 (org.eclipse.ajdt.feature.group 2.1.3.e37x-20110628-1900)
Only one of the following can be installed at once:
Search Support 3.8.0.v20120523-1540 (org.eclipse.search 3.8.0.v20120523-1540)
Search Support 3.7.0.v20110505-0800 (org.eclipse.search 3.7.0.v20110505-0800)
Search Support 3.6.0.v20100520-0800 (org.eclipse.search 3.6.0.v20100520-0800)
Search Support 3.7.0.v20110928-1504 (org.eclipse.search 3.7.0.v20110928-1504)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.5.0.20120614-1633 (epp.package.jee 1.5.0.20120614-1633)
To: org.eclipse.epp.package.jee.feature.feature.group [1.5.0.20120614-1633]
Cannot satisfy dependency:
From: AspectJ Development Tools 2.1.3.e37x-20110628-1900 (org.eclipse.ajdt.feature.group 2.1.3.e37x-20110628-1900)
To: org.eclipse.ajdt.ui [2.1.3.e37x-20110628-1900]
Cannot satisfy dependency:
From: AspectJ Development Tools UI 2.1.3.e37x-20110628-1900 (org.eclipse.ajdt.ui 2.1.3.e37x-20110628-1900)
To: bundle org.eclipse.search [3.6.0,3.8.0)
Cannot satisfy dependency:
From: Java EE IDE Feature 1.5.0.20120614-1633 (org.eclipse.epp.package.jee.feature.feature.group 1.5.0.20120614-1633)
To: org.eclipse.platform.feature.group [4.2.0.v20120608-135145-9JF7BHV8FyMteji0Oi_ePMz0xuZ8TVo7lV0z0ecb]
Cannot satisfy dependency:
From: Eclipse Platform 4.2.0.v20120608-135145-9JF7BHV8FyMteji0Oi_ePMz0xuZ8TVo7lV0z0ecb (org.eclipse.platform.feature.group 4.2.0.v20120608-135145-9JF7BHV8FyMteji0Oi_ePMz0xuZ8TVo7lV0z0ecb)
To: org.eclipse.search [3.8.0.v20120523-1540]
Re: Have functional but non-updatable platform [message #895884 is a reply to message #895670] Mon, 16 July 2012 12:41 Go to previous message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

You can't update from Eclipse 3.x to Juno (based on eclipse 4.2). You have to grab a new download, either eclipse Classic SDK or one of the pre-packaged version from http://www.eclipse.org/downloads/ Unzip it (not over an existing install) and go.

Then install the Juno compatible plugins into your eclipse.

PW


Previous Topic:Allow only one product instance by workspace
Next Topic:Implementing folder/files as derived
Goto Forum:
  


Current Time: Sun Oct 26 06:16:13 GMT 2014

Powered by FUDForum. Page generated in 0.01495 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software