Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Error during installation of Eclipse Indigo(Error during installation of Eclipse Indigo)
Error during installation of Eclipse Indigo [message #895630] Fri, 13 July 2012 21:01 Go to next message
Kirthiga Narayanan is currently offline Kirthiga NarayananFriend
Messages: 2
Registered: July 2012
Junior Member
Hi,
I have a Windows 7 (64 bit) computer. I downloaded eclipse-jee-indigo-SR2-win32-x86-64.exe and installed eclipse on my computer.
I also have Java 1.7.0_05 (64 bit) on my computer. But when I start eclipse, I get the following error message

Java was started but returned exit code 13

When I googled, all I could find was the error message is because of an incompatibility between the JVM , but as far as I can tell they are in synch.

Any ideas ?

Thanks
Kirthiga N
Re: Error during installation of Eclipse Indigo [message #895650 is a reply to message #895630] Sat, 14 July 2012 05:07 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26234
Registered: July 2009
Senior Member
Have you tried specifying which JVM Eclipse should use with a -vm argument?

http://help.eclipse.org/indigo/index.jsp?topic=%2Forg.eclipse.platform.doc.isv%2Freference%2Fmisc%2Fruntime-options.html

On 13/07/2012 11:01 PM, Kirthiga Narayanan wrote:
> Hi,
> I have a Windows 7 (64 bit) computer. I downloaded
> eclipse-jee-indigo-SR2-win32-x86-64.exe and installed eclipse on my
> computer.
> I also have Java 1.7.0_05 (64 bit) on my computer. But when I start
> eclipse, I get the following error message
>
> Java was started but returned exit code 13
>
> When I googled, all I could find was the error message is because of
> an incompatibility between the JVM , but as far as I can tell they are
> in synch.
>
> Any ideas ?
>
> Thanks
> Kirthiga N
Re: Error during installation of Eclipse Indigo [message #895671 is a reply to message #895650] Sat, 14 July 2012 15:12 Go to previous message
Kirthiga Narayanan is currently offline Kirthiga NarayananFriend
Messages: 2
Registered: July 2012
Junior Member
Hi,
I fixed the issue, looks like even though my OS windows 7 is a 64 bit OS, only a 32 bit Eclipse runs successfully.

Steps taken to fix the issue
1.Install 32 bit Eclipse Indigo
2.Install Java 1.5 32 bit
3.Update eclipse.ini to modify the following properties
From
--launcher.XXMaxPermSize
256M

To
--launcher.XXMaxPermSize
512M

From
-Xmx512m

To
-Xmx768m

Eclipse starts successfully now. Thanks.
Previous Topic:What are the most important architecture parts of Eclipse?
Next Topic:Error after upgrading from Indigo to Juno
Goto Forum:
  


Current Time: Thu Nov 27 17:43:21 GMT 2014

Powered by FUDForum. Page generated in 0.01895 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software