Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Content Assist bug?
Content Assist bug? [message #894168] Sat, 07 July 2012 08:02
Brigham White is currently offline Brigham White
Messages: 3
Registered: July 2012
Junior Member
Quote:
Hello, I have spent over an hour attempting to disable ALL auto-complete and suggestions in the Android SDK in Eclipse. Android uses both XML and Java files. Currently I have been working on XML files and every time I reach an end of line I hit [Enter], but there is an auto-complete dialogue up and it prints "style" at the end of the line.

Any assistance would be great, I have been searching online and have been turning EVERYTHING off in:
Windows -> Preferences -> Java -> Editor
Windows -> Preferences -> XML -> XML Files -> Editor

While I finally got closing tags and quotes from popping up, this irritating and downright WRONG auto-complete keeps popping up.

If there is some overall disable switch that I am missing I will feel stupid, but would be grateful for the assistance.

Thanks for all your assistance.


Hello All! The above quoted text is the exact same issue I'm having. Unfortunately it was posted in January of 2011 and received no replies which makes me wonder if this is a bug. I have tried on Eclipse 3.6.2, 3.7.2, SR2, and as also said above, I have disabled all options in every platform related to auto completion or content assist. I have spent about two days messing with all manner of settings and researching online how to solve this problem. The general advice in other forums for other platforms with the same problem, not just XML, is almost always to go "Window->preferences->[platform]->Editor->Content Assist (and/or) Typing" and disable the relevant options. Half the people claim it fixes their problem.. the other half claim it does not.. I happen to be with the "does not" crowd as everything I've tried has no effect.. even after shutting down and restarting Eclipse. And the options are all still disabled after the restart. I'm starting to get desperate as this is really cramping my coding style.. Is this a bug? Or am I just missing something? Thank you!
Previous Topic:Hey Diddle Diddle...
Next Topic:c/c++
Goto Forum:
  


Current Time: Fri Oct 31 15:05:39 GMT 2014

Powered by FUDForum. Page generated in 0.01671 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software