Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Problem installing Jubula. setup.sh fails with bin/unpack200: not found
Problem installing Jubula. setup.sh fails with bin/unpack200: not found [message #893607] Wed, 04 July 2012 20:10 Go to next message
Niklaus Giger is currently offline Niklaus GigerFriend
Messages: 11
Registered: August 2011
Junior Member
I am a satisfied Jubula user and Jubula proved to be a good tool to ensure a good quality for new releases! Many thanks!

Now I am trying to setup a Jubula/Jenkins integration server using vagrant.

I installed Ubuntu 12.04 LTS (64-bit AMD) in a VirtualBox and I am getting a weired error trying to install the latest Jubula setup.sh
md5sum setup.sh
f6b25c275319dbbdb7e7562b382b89bb setup.sh
sudo ./setup.sh
Unpacking JRE ...
Preparing JRE ...
./setup.sh: 197: ./setup.sh: bin/unpack200: not found
Error unpacking jar files. Aborting.
You might need administrative priviledges for this operation.

I tried both java-6 and java-7, using sudo or not, setting JAVA_HOME=/usr/lib/jvm/default-java/ but nothing helped.

/usr/lib/jvm/default-java/bin/unpack200 -h gives some help text.

Are there any hidden dependencies on installed jars or other packages?

Any ideas?
Re: Problem installing Jubula. setup.sh fails with bin/unpack200: not found [message #893651 is a reply to message #893607] Thu, 05 July 2012 06:43 Go to previous messageGo to next message
Achim Loerke is currently offline Achim LoerkeFriend
Messages: 357
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

Thanks for the thanks Smile

I haven't seen this problem before. There are times when we get similar problems with parts of the JVM missing in our VMware instances but that are sporadic problems which go away the next run. We suspect that some problems in network access causes them.

I'd like to have this investigated. Would you please file a bug in Eclipse bugzilla. Please keep our guidelines in mind.

Thanks for your help

Achim
Re: Problem installing Jubula. setup.sh fails with bin/unpack200: not found [message #893656 is a reply to message #893607] Thu, 05 July 2012 06:54 Go to previous message
Zeb Ford-Reitz is currently offline Zeb Ford-ReitzFriend
Messages: 32
Registered: November 2010
Member
I've seen this problem before. If I remember correctly, the issue is that the Linux installer is 32-bit. As you are on a 64-bit system, the required 32-bit libraries are missing. You should be able to install the necessary 32-bit libraries on Ubuntu with the command:
sudo apt-get install ia32-libs

Once you've got the libraries, the installer should run fine. If that still doesn't work, then please file a bug, as per Achim's post. Even if it works, you could file an enhancement for a 64-bit installer or some documentation that 32-bit libs are required.
Previous Topic:re-using the test scripts
Next Topic:EclipseCon Europe Call for Papers
Goto Forum:
  


Current Time: Sat Dec 20 06:50:48 GMT 2014

Powered by FUDForum. Page generated in 0.01712 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software