Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP work on Windows but not working on Linux
RAP work on Windows but not working on Linux [message #893412] Wed, 04 July 2012 03:04 Go to next message
viet minh vu is currently offline viet minh vuFriend
Messages: 2
Registered: July 2012
Junior Member
Hi,
I deploy a RAP project (file WAR) on server Tomcat on Windows, it's running well. But when I deploy this WAR file on server Tomcat on Linux, I can not run this website, it has a problem as below error log.
(before plugin BIRT to my project, it run well on Linux, after I add BIRT to my project it has this problem).

Please help me to solve this. I want to run this project on Linux.
Thank you so much.


Here is log error:

Jul 4, 2012 9:08:29 PM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet equinoxbridgeservlet threw exception
java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Display
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Class.java:2389)
at java.lang.Class.getConstructor0(Class.java:2699)
at java.lang.Class.getConstructor(Class.java:1657)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2568)
at org.eclipse.ui.internal.Workbench.access$5(Workbench.java:2530)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:702)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:685)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:157)
at com.saltlux.ucsmanagement.Application.start(Application.java:18)
at org.eclipse.rap.ui.internal.application.EntryPointApplicationWrapper.createUI(EntryPointApplicationWrapper.java:38)
at org.eclipse.rwt.internal.lifecycle.RWTLifeCycle.createUI(RWTLifeCycle.java:177)
at org.eclipse.rwt.internal.lifecycle.RWTLifeCycle$UIThreadController.run(RWTLifeCycle.java:289)
at java.lang.Thread.run(Thread.java:662)
at org.eclipse.rwt.internal.lifecycle.UIThread.run(UIThread.java:102)
org.apache.catalina.core.StandardWrapperValve invokeSEVERE: Servlet.service() for servlet equinoxbridgeservlet threw exceptionequinoxbridgeservlet



[Updated on: Wed, 04 July 2012 07:15]

Report message to a moderator

Re: RAP work on Windows but not working on Linux [message #893430 is a reply to message #893412] Wed, 04 July 2012 07:21 Go to previous message
viet minh vu is currently offline viet minh vuFriend
Messages: 2
Registered: July 2012
Junior Member
I attach file error for more detail.
Please help me Sad

  • Attachment: error.png
    (Size: 67.75KB, Downloaded 72 times)
Previous Topic:How to handle non blocking JFace Dialog
Next Topic:Experiences with RAP
Goto Forum:
  


Current Time: Thu Nov 27 14:40:29 GMT 2014

Powered by FUDForum. Page generated in 0.10038 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software