Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGL Development Tools » [Requesting feedback] Drop support for Eclipse 3.6?
[Requesting feedback] Drop support for Eclipse 3.6? [message #893122] Mon, 02 July 2012 17:39 Go to next message
Matt Heitz is currently offline Matt HeitzFriend
Messages: 36
Registered: July 2009
Member
Hi EDT Community,

We'd like your opinion about the versions of Eclipse that EDT supports. It currently runs in Eclipse 3.6 (Helios) and 3.7 (Indigo). It probably works with the new 4.2 (Juno) release too, though we haven't tested that yet.

Some of our code could be improved if we dropped the requirement to support 3.6. We'd support 3.7 and 4.2 instead. The change would happen in the release following EDT 0.8.1, which is currently under development.

How do you feel about this idea? Is Eclipse 3.6 support important to you?

-Matt
Re: [Requesting feedback] Drop support for Eclipse 3.6? [message #893613 is a reply to message #893122] Wed, 04 July 2012 21:50 Go to previous messageGo to next message
Dan Darnell is currently offline Dan DarnellFriend
Messages: 145
Registered: November 2011
Location: Arkansas
Senior Member

I'd drop 3.6 like a hot potato.

--Dan
Re: [Requesting feedback] Drop support for Eclipse 3.6? [message #893657 is a reply to message #893122] Thu, 05 July 2012 06:59 Go to previous messageGo to next message
Richard Moulton is currently offline Richard MoultonFriend
Messages: 92
Registered: August 2011
Location: Devon, UK
Member
Matt,

Personally, I'd keep as close as possible to the current eclipse version, so no problem from me dropping support for 3.6.

Richard
Re: [Requesting feedback] Drop support for Eclipse 3.6? [message #893897 is a reply to message #893657] Thu, 05 July 2012 21:11 Go to previous messageGo to next message
Billy Weeks is currently offline Billy WeeksFriend
Messages: 6
Registered: May 2012
Location: Norcross, GA
Junior Member
I would also suggest dropping 3.6.
Re: [Requesting feedback] Drop support for Eclipse 3.6? [message #894800 is a reply to message #893122] Tue, 10 July 2012 14:52 Go to previous message
Matt Heitz is currently offline Matt HeitzFriend
Messages: 36
Registered: July 2009
Member
Thanks for your responses.

Our decision is that the next release (EDT 0.8.2) will support Eclipse 3.6,
3.7, and 4.2. However, we will only test it with 3.7 and 4.2. We'll say that
we expect EDT to work with 3.6. If a user reports a bug with EDT on 3.6, we
will fix it.

-Matt
Previous Topic:More issues with IBM i program calls
Next Topic:Application Development Cover Story -- No EGL?!
Goto Forum:
  


Current Time: Sun Nov 23 13:47:25 GMT 2014

Powered by FUDForum. Page generated in 0.01795 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software