Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Problem installing Papyrus 0.9.0.v201207020923
Problem installing Papyrus 0.9.0.v201207020923 [message #893049] Mon, 02 July 2012 12:42 Go to next message
Carlos Gomez is currently offline Carlos GomezFriend
Messages: 25
Registered: October 2010
Junior Member
Hello everybody,

I'm trying to install the last version of Papyrus in Juno (0.9.0.v201207020923), but I get the following error:

Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus Extra Binaries and Sources (Incubation) 0.9.0.v201207020923 (org.eclipse.papyrus.extra.sources.feature.feature.group 0.9.0.v201207020923)
Missing requirement: Papyrus UML Merger (Incubation) 0.9.0.v201207020923 (org.eclipse.papyrus.uml.compare.diff 0.9.0.v201207020923) requires 'bundle org.eclipse.emf.compare.uml2 1.3.1' but it could not be found
Cannot satisfy dependency:
From: Papyrus Extra Feature (Incubation) 0.9.0.v201207020923 (org.eclipse.papyrus.extra.feature.feature.group 0.9.0.v201207020923)
To: org.eclipse.papyrus.extra.uml.compare.feature.feature.group [0.9.0.v201207020923]
Cannot satisfy dependency:
From: Papyrus Extra Binaries and Sources (Incubation) 0.9.0.v201207020923 (org.eclipse.papyrus.extra.sources.feature.feature.group 0.9.0.v201207020923)
To: org.eclipse.papyrus.extra.feature.feature.group [0.9.0.v201207020923]
Cannot satisfy dependency:
From: Compare UML Feature (Incubation) 0.9.0.v201207020923 (org.eclipse.papyrus.extra.uml.compare.feature.feature.group 0.9.0.v201207020923)
To: org.eclipse.papyrus.uml.compare.diff [0.9.0.v201207020923]

Does anybody have the same problem?

Thanks for your help!!!
Re: Problem installing Papyrus 0.9.0.v201207020923 [message #893054 is a reply to message #893049] Mon, 02 July 2012 12:49 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 511
Registered: February 2011
Senior Member
Hello,


The recommended version to use is the one provided with the Juno release train (http://download.eclipse.org/releases/juno/), then use the Papyrus discovery site to install extra-features (Help > Install Papyrus Additional Components). You shouldn't have any dependency problem.

However, if you're aware that you're using the Papyrus nightly builds at your own risk, don't forget to check the following option: "Contact all update sites during install to find required software" (Or install EMF Compare from the Juno release update site before you try to install Papyrus Compare Editor).


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Problem installing Papyrus 0.9.0.v201207020923 [message #893059 is a reply to message #893049] Mon, 02 July 2012 12:49 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

You are installing post-Juno code, so you will have to work hard to find
the corresponding post-Juno dependencies. Your problem is finiding the
EMF Compare maintence release that is not due for release for another 3
months.

Regards

Ed Willink


On 02/07/2012 13:42, Carlos Gomez wrote:
> Hello everybody,
>
> I'm trying to install the last version of Papyrus in Juno
> (0.9.0.v201207020923), but I get the following error:
>
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: Papyrus Extra Binaries and Sources
> (Incubation) 0.9.0.v201207020923
> (org.eclipse.papyrus.extra.sources.feature.feature.group
> 0.9.0.v201207020923)
> Missing requirement: Papyrus UML Merger (Incubation)
> 0.9.0.v201207020923 (org.eclipse.papyrus.uml.compare.diff
> 0.9.0.v201207020923) requires 'bundle org.eclipse.emf.compare.uml2
> 1.3.1' but it could not be found
> Cannot satisfy dependency:
> From: Papyrus Extra Feature (Incubation) 0.9.0.v201207020923
> (org.eclipse.papyrus.extra.feature.feature.group 0.9.0.v201207020923)
> To: org.eclipse.papyrus.extra.uml.compare.feature.feature.group
> [0.9.0.v201207020923]
> Cannot satisfy dependency:
> From: Papyrus Extra Binaries and Sources (Incubation)
> 0.9.0.v201207020923
> (org.eclipse.papyrus.extra.sources.feature.feature.group
> 0.9.0.v201207020923)
> To: org.eclipse.papyrus.extra.feature.feature.group
> [0.9.0.v201207020923]
> Cannot satisfy dependency:
> From: Compare UML Feature (Incubation) 0.9.0.v201207020923
> (org.eclipse.papyrus.extra.uml.compare.feature.feature.group
> 0.9.0.v201207020923)
> To: org.eclipse.papyrus.uml.compare.diff [0.9.0.v201207020923]
>
> Does anybody have the same problem?
> Thanks for your help!!!
Re: Problem installing Papyrus 0.9.0.v201207020923 [message #893062 is a reply to message #893059] Mon, 02 July 2012 12:59 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 511
Registered: February 2011
Senior Member
Ed,

EMF Compare have actually already released their 1.3.1 version (I believe they reused a previous version in Juno, instead of providing an 1.4.0 or 2.0.0, which explains the ".1"). So, there shouldn't be any problem for installing a nightly build of Papyrus here. We're not depending on unreleased builds (yet).


Camille


Camille Letavernier
Papyrus developer
Re: Problem installing Papyrus 0.9.0.v201207020923 [message #893842 is a reply to message #893062] Thu, 05 July 2012 16:23 Go to previous messageGo to next message
Carlos Gomez is currently offline Carlos GomezFriend
Messages: 25
Registered: October 2010
Junior Member
Thanks Camille and Ed,

I'll work with the release version.
Re: Problem installing Papyrus 0.9.0.v201207020923 [message #1021062 is a reply to message #893049] Tue, 19 March 2013 13:03 Go to previous message
danny knoll is currently offline danny knollFriend
Messages: 1
Registered: March 2013
Junior Member
I've had the same problem, on eclipse juno sr2.

my solution was to download the latest release from
http://www.eclipse.org/papyrus/downloads/index.php

this was
http://www.eclipse.org/modeling/download.php?file=/modeling/mdt/papyrus/downloads/drops/0.9.2/R201302130602/Papyrus-Update-incubation-0.9.2.zip

and in eclipse I went to help->install new software and than i used the archieve and not the url,
after manual installaition it is also possible with help->add papyrus additional components to install furtcher stuff
I hope it helps
Previous Topic:Show/Hide contents question
Next Topic:Should the New Papyrus Model action also create complete diagrams for existing UML model elements?
Goto Forum:
  


Current Time: Sat Dec 20 18:46:59 GMT 2014

Powered by FUDForum. Page generated in 0.08663 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software