Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse Juno on Fedora 17 update problems(Update failing with dependancy issues)
Eclipse Juno on Fedora 17 update problems [message #893039] Mon, 02 July 2012 12:03 Go to next message
Da Foot is currently offline Da FootFriend
Messages: 1
Registered: July 2012
Junior Member
I'm trying to update my Juno installation using the Eclipse 'check for updates' process but I'm getting an error about dependancies that I need some help to overcome.

Eclipse was installed direct from the Fedora repositories.

The log appears to suggest platform 3.7 is installed but when trying to update to 4.2 the update fails.

Firstly... am I reading that error correctly? Embarrassed
Secondly... how do I fix it?! Razz

Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Project SDK 4.2.0.v20120528-1648-7T7oDFDPz-3FepgRqG6kkFFY0UF4_otgmt0XcoU3Zh27X (org.eclipse.sdk.feature.group 4.2.0.v20120528-1648-7T7oDFDPz-3FepgRqG6kkFFY0UF4_otgmt0XcoU3Zh27X)
  Software currently installed: Eclipse Platform 3.7.0.I20120503-1800 (org.eclipse.platform.ide 3.7.0.I20120503-1800)
  Only one of the following can be installed at once: 
    Eclipse e4 Workbench Add-ons 0.10.1.v20120523-1955 (org.eclipse.e4.ui.workbench.addons.swt 0.10.1.v20120523-1955)
    Eclipse e4 Workbench Add-ons 0.10.0.v20120502-1520 (org.eclipse.e4.ui.workbench.addons.swt 0.10.0.v20120502-1520)
  Cannot satisfy dependency:
    From: Eclipse e4 Rich Client Platform 1.1.0.v20120131-1846-9TFjYG0nGMHbln2aSI5AGXHS (org.eclipse.e4.rcp.feature.group 1.1.0.v20120131-1846-9TFjYG0nGMHbln2aSI5AGXHS)
    To: org.eclipse.e4.ui.workbench.addons.swt [0.10.0.v20120502-1520]
  Cannot satisfy dependency:
    From: Eclipse e4 Rich Client Platform 1.1.0.v20120521-2329-8yFTIGF3GGduEYqkQB9M3DKn (org.eclipse.e4.rcp.feature.group 1.1.0.v20120521-2329-8yFTIGF3GGduEYqkQB9M3DKn)
    To: org.eclipse.e4.ui.workbench.addons.swt [0.10.1.v20120523-1955]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.2.0.v20120403-2031-9XF7gHH5G4t85Drg_joRGiBi4S2YkH7yZ7fuZ0 (org.eclipse.platform.feature.group 4.2.0.v20120403-2031-9XF7gHH5G4t85Drg_joRGiBi4S2YkH7yZ7fuZ0)
    To: org.eclipse.rcp.feature.group [4.2.0.v20120403-2031-7IAPA7BrnQz-rST2kRW01E3bTJ6B]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.2.0.v20120608-135145-9JF7BHV8FyMteji0Oi_ePMz0xuZ8TVo7lV0z0ecb (org.eclipse.platform.feature.group 4.2.0.v20120608-135145-9JF7BHV8FyMteji0Oi_ePMz0xuZ8TVo7lV0z0ecb)
    To: org.eclipse.rcp.feature.group [4.2.0.v20120528-1648-7IAPA7BrHQicRpNdOz-Obz-rlRCA]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.0.I20120503-1800 (org.eclipse.platform.ide 3.7.0.I20120503-1800)
    To: org.eclipse.platform.feature.group [4.2.0.v20120403-2031-9XF7gHH5G4t85Drg_joRGiBi4S2YkH7yZ7fuZ0]
  Cannot satisfy dependency:
    From: Eclipse RCP 4.2.0.v20120403-2031-7IAPA7BrnQz-rST2kRW01E3bTJ6B (org.eclipse.rcp.feature.group 4.2.0.v20120403-2031-7IAPA7BrnQz-rST2kRW01E3bTJ6B)
    To: org.eclipse.e4.rcp.feature.group [1.1.0.v20120131-1846-9TFjYG0nGMHbln2aSI5AGXHS]
  Cannot satisfy dependency:
    From: Eclipse RCP 4.2.0.v20120528-1648-7IAPA7BrHQicRpNdOz-Obz-rlRCA (org.eclipse.rcp.feature.group 4.2.0.v20120528-1648-7IAPA7BrHQicRpNdOz-Obz-rlRCA)
    To: org.eclipse.e4.rcp.feature.group [1.1.0.v20120521-2329-8yFTIGF3GGduEYqkQB9M3DKn]
  Cannot satisfy dependency:
    From: Eclipse Project SDK 4.2.0.v20120528-1648-7T7oDFDPz-3FepgRqG6kkFFY0UF4_otgmt0XcoU3Zh27X (org.eclipse.sdk.feature.group 4.2.0.v20120528-1648-7T7oDFDPz-3FepgRqG6kkFFY0UF4_otgmt0XcoU3Zh27X)
    To: org.eclipse.platform.feature.group [4.2.0.v20120608-135145-9JF7BHV8FyMteji0Oi_ePMz0xuZ8TVo7lV0z0ecb]
Re: Eclipse Juno on Fedora 17 update problems [message #893055 is a reply to message #893039] Mon, 02 July 2012 12:50 Go to previous message
Sopot Cela is currently offline Sopot CelaFriend
Messages: 597
Registered: December 2010
Senior Member

I guess you need to download from eclipse.org/downloads directly as fedora may not have the latest versions
Previous Topic:Official upgrade route for 3.x to Juno
Next Topic:Eclipse JEE Juno JDK version requirement?
Goto Forum:
  


Current Time: Mon Dec 22 05:00:50 GMT 2014

Powered by FUDForum. Page generated in 0.01753 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software