Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Multiple subversive m2e integration projects
Multiple subversive m2e integration projects [message #892888] Sun, 01 July 2012 12:54
Stevo Slavic is currently offline Stevo SlavicFriend
Messages: 21
Registered: July 2009
Junior Member
Subversive Integrations project provided m2eclipse 0.12 integration. Then m2e 1.0 got released as eclipse project, and Subversive M2eclipse integration has made it into Sonatype's m2eclipse-subversive project and was catalogued in m2e connectors. Then Sonatype couldn't maintain project anymore and even suggested to the community to fork the project ( https: //github.com/sonatype/m2eclipse-subversive/pull/1#issuecomment-4046475 ). This resulted in Subversive integration not being compatible/available for m2e 1.1 betas. Then Subversive Integration project get m2e support back in (see https: //bugs.eclipse.org/bugs/show_bug.cgi?id=381454 ) and got released ( available at http: //community.polarion.com/projects/subversive/download/integrations/update-site/ ). It's not listed in m2e connectors catalog. Recently m2e-subversive @ Sonatype is being developed again but lacks Subversive expertise ( https: //github.com/sonatype/m2eclipse-subversive/commit/ebc19fddb5c1b7e16136cd7b0e22d711a29f1f4a ).

I don't understand this, who could possibly gain from this sort of mess, but it's not the community of neither Subversive nor m2e.

If making Subversive Integrations a eclipse project (Subversive subproject) would help, then please do it.

In ideal world this integration would be released together with eclipse, m2e, and subversive.

Kind regards,
Stevo.
Previous Topic:upgrading to Juno
Next Topic:Viewing History and Annotations from Compare View
Goto Forum:
  


Current Time: Fri Nov 28 08:43:57 GMT 2014

Powered by FUDForum. Page generated in 0.02384 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software