Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Installing EGit
Installing EGit [message #892830] Sat, 30 June 2012 05:52 Go to next message
John Muller is currently offline John Muller
Messages: 1
Registered: June 2012
Junior Member
There are two different repositories for installing EGit, the "Indigo Update Site", and the "EGit P2 Repository". Which one should I install from?

Also, there are many different options to select when installing EGit.

From the Indigo Update Site:
- Eclipse EGit
- Eclipse EGit Mylyn GitHub Feature
- Eclipse JGit
- EGit Mylyn

From the EGit P2 Repository:
- Eclipse EGit
- Eclipse EGit - Source
- EGit Import Support
- EGit Mylyn
- EGit Project Set Support
- Eclipse JGit
- Eclipse JGit - Source
- Eclipse JGit Command Line Interface
- Eclipse JGit Command Line Interface - Source

What do these options do, and which ones are recommended for installation?

[Updated on: Sat, 30 June 2012 05:53]

Report message to a moderator

Re: Installing EGit [message #892863 is a reply to message #892830] Sat, 30 June 2012 18:09 Go to previous messageGo to next message
Chris Aniszczyk is currently offline Chris Aniszczyk
Messages: 674
Registered: July 2009
Senior Member
Eclipse EGit should bring in everything you need automatically.

If you want EGit Mylyn (http://eclipse.github.com/) support, download the Eclipse EGit Mylyn GitHub Feature.

HTH
Re: Installing EGit [message #893038 is a reply to message #892830] Mon, 02 July 2012 12:01 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 594
Registered: July 2009
Senior Member
The "Indigo" p2 repository has the last release which was shipped with Indigo SR2 which is 1.3.
The "Juno" p2 repository has the last release shipped with Juno which is currently 2.0
The "EGit" repository always has the latest release which is currently 2.0.

The EGit feature is the main EGit feature implementing the git team provider and corresponding workbench integration, it depends on JGit so this will be also installed when you select EGit.

The EGit Mylyn feature adds EGit Mylyn integration.

EGit Project Set Support is required for platform versions < 3.7 (Helios and older) to enable EGit support for project sets.

EGit Import Support allows to clone source repository for an installed bundle which carries the Eclipse-SourceReference manifest header. This requires Juno platform version (Eclipse 4.2) since it depends on a new method in the team API.
Re: Installing EGit [message #893075 is a reply to message #893038] Mon, 02 July 2012 13:43 Go to previous message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
On 02.07.2012 14:01, Matthias Sohn wrote:
> EGit Import Support allows to clone source repository for an installed
> bundle which carries the Eclipse-SourceReference manifest header. This
> requires Juno platform version (Eclipse 4.2) since it depends on a new
> method in the team API.
It also works with 3.8.

Dani
Previous Topic:Gitmodules Ignore Flag Not Honored?
Next Topic:Remove project from workspace only
Goto Forum:
  


Current Time: Fri Oct 31 16:00:14 GMT 2014

Powered by FUDForum. Page generated in 0.18288 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software