Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Invoking custom XMLContentAssistProcessor
Invoking custom XMLContentAssistProcessor [message #892822] Fri, 29 June 2012 18:15 Go to next message
rohit chawla is currently offline rohit chawla
Messages: 19
Registered: June 2012
Junior Member
Hi everyone,

I am failing to invoke my inherited class of my custom sourceViewerConfiguration class. As a result not able to invoke my inherited class of XMLContentAssistProcessor? These are the steps, which I have done. Please let me know, where I am going wrong?

My plugin.xml file

<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.4"?>
<plugin>

<extension
point="org.eclipse.core.runtime.contentTypes">
<content-type
id="com.xyz.ide.core.contentType.dummy"
base-type="org.eclipse.core.runtime.xml"
file-extensions="xyz"
name="mypage"
priority="normal"
default-charset="UTF-8"/>
</extension>


<extension
point="org.eclipse.wst.sse.ui.editorConfiguration">
<sourceViewerConfigurtation
class="validation.MyStructuredXMLConfiguration"
target="com.xyz.ide.core.contentType.dummy"/>
</extension>


</plugin>

Is there something wrong in this plugin.xml file?

[Updated on: Fri, 29 June 2012 18:55]

Report message to a moderator

Re: Invoking custom XMLContentAssistProcessor [message #892827 is a reply to message #892822] Fri, 29 June 2012 22:39 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2250
Registered: July 2009
Senior Member
Unless you've copied and pasted wrong, the sourceViewerConfiguration element's name is misspelled in your file.

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Invoking custom XMLContentAssistProcessor [message #893314 is a reply to message #892827] Tue, 03 July 2012 10:07 Go to previous message
rohit chawla is currently offline rohit chawla
Messages: 19
Registered: June 2012
Junior Member
Thanks Nitin, yes that was the mistake.
Previous Topic:Prevent Eclispe content-assistance from xsd for the namespace, which is not declared in xml
Next Topic:unable to start jboss server eclipsce in debug mode
Goto Forum:
  


Current Time: Wed Aug 20 20:38:38 EDT 2014

Powered by FUDForum. Page generated in 0.01492 seconds