Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » SWT Browser - 64bit windows - still IE only?
SWT Browser - 64bit windows - still IE only? [message #892815] Fri, 29 June 2012 20:38 Go to next message
Sharon Snyder is currently offline Sharon Snyder
Messages: 56
Registered: September 2010
Member

I'm in the process of migrating my RCP application to Juno from 3.6. One reason (but not the only one) is the browser widget. We want to use Chrome or Mozilla - and maybe even the later versions of IE. Yes, we are a windows only shop - and there is no way we can move off of it. My questions are:

Is it still really true that the only way to switch browser engines is to use 32bit Eclipse???? I'm using 64bit, and am not inclined to force my users to use 32 bit if I don't have to - my boss will kill me if this is the case.

How do I tell the renderer to run IE 8 or 9 vs. the IE7 it keeps loading?

Thanks.

Sharon
Re: SWT Browser - 64bit windows - still IE only? [message #892837 is a reply to message #892815] Sat, 30 June 2012 07:30 Go to previous messageGo to next message
Simon Scholz is currently offline Simon Scholz
Messages: 73
Registered: April 2012
Location: Germany
Member
Hi Sharon,

maybe the recent post concerning HTML 5 helps you:

www.eclipse.org/forums/index.php/mv/msg/360353/884302/#msg_884302

I guess the response of Grant Gayed and me is interesting for you:

It concerns the usage of a xulrunner and the SWT.MOZILLA flag for the SWT Browser and the fact that Eclipse 3.7 uses newer IE Browsers, but Eclipse 3.6.x uses IE7.

Hopefully your boss will not kill you Laughing , but why not using 32 bit for your RCP client?
I do not think 64 bit is really necessary for a java application...there are too many compatibility lacks between 32 and 64 bit.

So why do you need 64 bit?

Best regards,

Simon

[Updated on: Sat, 30 June 2012 07:30]

Report message to a moderator

Re: SWT Browser - 64bit windows - still IE only? [message #893066 is a reply to message #892837] Mon, 02 July 2012 13:07 Go to previous messageGo to next message
Sharon Snyder is currently offline Sharon Snyder
Messages: 56
Registered: September 2010
Member

Hi Simon,

Thanks for responding. I thought that maybe something had changed since 2009, but it doesn't sound like it. As I mentioned we are upgrading our Eclipse version, so that will help.

I tried to use Eclipse Juno to test out the browser functionality, but only on 64 bit so far. Today I'm going to try to see what I can do using a 32 bit setup of Eclipse Juno. Hopefully it will work as advertised. Smile

We were using 64 bit for performance and memory. Some of our users keep our product running all week and sometimes when memory usage gets high. These are not leaks, but the way the application was initially designed....which, of course, is not how they are using it! While we've fixed some of the memory issues to better match their usage, some will most likely remain as-is.

Thanks,
Sharon
Re: SWT Browser - 64bit windows - still IE only? [message #894017 is a reply to message #893066] Fri, 06 July 2012 12:09 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de Alwis
Messages: 242
Registered: July 2009
Senior Member
See the following bugs for details:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=374600
https://bugs.eclipse.org/bugs/show_bug.cgi?id=199660
Re: SWT Browser - 64bit windows - still IE only? [message #894031 is a reply to message #894017] Fri, 06 July 2012 12:44 Go to previous messageGo to next message
Sharon Snyder is currently offline Sharon Snyder
Messages: 56
Registered: September 2010
Member

Thanks Brian. In other words, it doesn't look like it will be supported anytime soon in 64 bit!
Re: SWT Browser - 64bit windows - still IE only? [message #1082898 is a reply to message #894031] Fri, 09 August 2013 07:09 Go to previous message
Hardi Patel is currently offline Hardi Patel
Messages: 1
Registered: August 2013
Junior Member
I want to use IE comapability version.
I have tried :
-Dorg.eclipse.swt.browser.IEVersion=70000
-Dorg.eclipse.swt.browser.IEVersion=8888

But its not working, Please help me waiting for your valuable reply.

Thanks in advance.
Previous Topic:Error 404 in custom help browser tab
Next Topic:Change "Package Presentation" of Common Navigator
Goto Forum:
  


Current Time: Wed Oct 01 16:20:34 GMT 2014

Powered by FUDForum. Page generated in 0.01633 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software