Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Version to use in Indigo SR2?
Version to use in Indigo SR2? [message #892786] Fri, 29 June 2012 12:29 Go to next message
Stephan Herrmann is currently offline Stephan Herrmann
Messages: 997
Registered: July 2009
Senior Member
I'm having trouble finding a combination of subversive plus connector that works in Indigo SR2.

The newest version < 1.0.0 of subversive that I can find is 0.7.9.I20110919-1700, whereas the connectors from http://community.polarion.com/projects/subversive/download/eclipse/2.0/update-site/ (tried JavaHL as well as SVNKit) seem to require subversive 0.7.9.I20120413-1700.

Maybe someone did a bit too much cleanup for Juno? Smile

Either previous versions of connectors (like SVNKit 2.2.2) should be restored at polarion repos or subversive 0.7.9.I20120413-1700 should be published in some eclipse.org repo.

best,
Stephan
Re: Version to use in Indigo SR2? [message #898965 is a reply to message #892786] Sun, 29 July 2012 12:47 Go to previous messageGo to next message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Il 29/06/2012 18:29, Stephan Herrmann ha scritto:
> I'm having trouble finding a combination of subversive plus connector
> that works in Indigo SR2.

I successfully installed Subversive 1.0.0 in Indigo using the following
update site:
http://download.eclipse.org/technology/subversive/1.0/update-site/

HTH.
Mauro.
Re: Version to use in Indigo SR2? [message #898969 is a reply to message #898965] Sun, 29 July 2012 13:09 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan Herrmann
Messages: 997
Registered: July 2009
Senior Member
Mauro Molinari wrote on Sun, 29 July 2012 18:47
Il 29/06/2012 18:29, Stephan Herrmann ha scritto:
> I'm having trouble finding a combination of subversive plus connector
> that works in Indigo SR2.

I successfully installed Subversive 1.0.0 in Indigo using the following
update site:
http://download.eclipse.org/technology/subversive/1.0/update-site/


Thanks for the hint. I will try it.

But isn't it funny if a component that exists in the common Indigo repository cannot be installed from that repo? The Indigo version of subversive is 0.7.x. In a coordinated release a service release (Indigo SR2) shouldn't require a major update of one of its components.

Stephan
Re: Version to use in Indigo SR2? [message #899114 is a reply to message #898969] Mon, 30 July 2012 11:20 Go to previous message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Il 29/07/2012 19:09, Stephan Herrmann ha scritto:
> But isn't it funny if a component that exists in the common Indigo
> repository cannot be installed from that repo? The Indigo version of
> subversive is 0.7.x. In a coordinated release a service release (Indigo
> SR2) shouldn't require a major update of one of its components.

I suggest you to open a bug for this. Maybe it's like you said - a bit
too much cleanup for Juno.
Unfortunately, I already saw this kind of problems with other plugins in
past when new Eclipse versions are released :-(

Mauro.
Previous Topic:Program hangs on "Update SVN Cache"
Next Topic:Subversive/SVN compatibility
Goto Forum:
  


Current Time: Sat Aug 23 15:57:59 EDT 2014

Powered by FUDForum. Page generated in 0.01615 seconds