Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Browser Title won't change after switching locale(Locale switching won't work for browser title)
Browser Title won't change after switching locale [message #892611] Thu, 28 June 2012 17:42 Go to next message
Ronald So is currently offline Ronald So
Messages: 198
Registered: April 2011
Senior Member
Hello,

We are using the "title" attribute in org.eclipse.rap.ui.branding extension point to set the browser title for our RAP application. The title shows up fine in English but it won't change to other languages after switching to a different locale. We have set

Bundle-Localization: OSGI-INF/l10n/bundle


in the bundle manifest and we are using "%branding.title" and have this key defined in bundle_zh.properties under OSGI-INF/l10n folder.

We have logged a bug back in May but we never got a response. Just want to follow up on the issue so we can report back to our backlog.

This is the bug we logged.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=379979

Thanks!
Ronald
Re: Browser Title won't change after switching locale [message #893233 is a reply to message #892611] Tue, 03 July 2012 09:59 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1839
Registered: July 2009
Senior Member
Hi Roland,
sorry to the late response - we were busy with the Juno release last
weeks. We already investigated the issue and the bug is valid.
Unfortunately, there is no easy fix for it (without refactoring the
branding implementation).
Best,
Ivan

On 6/28/2012 8:42 PM, Ronald So wrote:
> Hello,
>
> We are using the "title" attribute in org.eclipse.rap.ui.branding
> extension point to set the browser title for our RAP application. The
> title shows up fine in English but it won't change to other languages
> after switching to a different locale. We have set
>
>
> Bundle-Localization: OSGI-INF/l10n/bundle
>
>
> in the bundle manifest and we are using "%branding.title" and have
> this key defined in bundle_zh.properties under OSGI-INF/l10n folder.
>
> We have logged a bug back in May but we never got a response. Just
> want to follow up on the issue so we can report back to our backlog.
>
> This is the bug we logged.
>
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=379979
>
> Thanks!
> Ronald

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Browser Title won't change after switching locale [message #895621 is a reply to message #893233] Fri, 13 July 2012 20:25 Go to previous message
Ronald So is currently offline Ronald So
Messages: 198
Registered: April 2011
Senior Member
Thanks for the update, Ivan.
Previous Topic:RAP 1.5 with Java 7
Next Topic:RAP, Eclipse E4 and SWT Browser Edition
Goto Forum:
  


Current Time: Sun Oct 26 04:00:32 GMT 2014

Powered by FUDForum. Page generated in 0.02326 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software