Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Wrong font on Eclipse Juno Editor Tabs
Wrong font on Eclipse Juno Editor Tabs [message #892431] Thu, 28 June 2012 08:19 Go to next message
Harald Wellmann is currently offline Harald Wellmann
Messages: 34
Registered: July 2009
Location: Hamburg, Germany
Member
I use Eclipse on Ubuntu 12.04 with KDE and the QtCurve theme which should apply all KDE style settings to GTK applications.

This works fine with Eclipse Indigo, but not with Eclipse Juno.

My standard font is Droid Sans 9 which is picked up by all widgets except the label on editor and view tabs, e.g. Project Explorer, which still looks like Sans 12.

Any ideas how to change this?

Best regards,
Harald
Re: Wrong font on Eclipse Juno Editor Tabs [message #892607 is a reply to message #892431] Thu, 28 June 2012 17:23 Go to previous messageGo to next message
Harald Wellmann is currently offline Harald Wellmann
Messages: 34
Registered: July 2009
Location: Hamburg, Germany
Member
OK, I've found the answer here: http://wiki.eclipse.org/Eclipse4/CSS.

I've installed the E4 CSS editor, and changed the font-size and font-family on .MPartStack to reduce my editor tabs to a reasonable size.

But there must be a better solution...
Re: Wrong font on Eclipse Juno Editor Tabs [message #892615 is a reply to message #892607] Thu, 28 June 2012 17:49 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Nope, that's it. We're working on the usability of modifying the CSS in 4.3

PW


Re: Wrong font on Eclipse Juno Editor Tabs [message #892648 is a reply to message #892615] Fri, 29 June 2012 00:34 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1341
Registered: July 2009
Senior Member
On 06/28/2012 12:49 PM, Paul Webster wrote:
> Nope, that's it. We're working on the usability of modifying the CSS in
> 4.3
>
> PW
>
The CSS should be complete and consistent out of the box. Users
shouldn't be expected to modify the CSS in order for Eclipse to be usable.
Re: Wrong font on Eclipse Juno Editor Tabs [message #893722 is a reply to message #892607] Thu, 05 July 2012 11:01 Go to previous messageGo to next message
Mihael Kukec is currently offline Mihael Kukec
Messages: 1
Registered: July 2012
Junior Member
Harald Wellmann wrote on Thu, 28 June 2012 13:23
OK, I've found the answer here: http://wiki.eclipse.org/Eclipse4/CSS.

I've installed the E4 CSS editor, and changed the font-size and font-family on .MPartStack to reduce my editor tabs to a reasonable size.

But there must be a better solution...


Harald and Paul have answered to this, but just to give clarification.

There is dot in the link. This one goes right to the solution Smile
http://wiki.eclipse.org/Eclipse4/CSS

Without instaling the editor, just edit this file:

eclipse/plugins/org.eclipse.platform_4.2.0.v201206081400/css/e4_default_gtk.css


This is the par ot the file to edit:

.MPartStack {
	font-size: 11;
	swt-simple: false;
	swt-mru-visible: false;
}


I've changed font-size to "9" and it looks much better now. I am using Ubuntu and also prefer smaller fonts than default settings.

[Updated on: Thu, 05 July 2012 11:21]

Report message to a moderator

Re: Wrong font on Eclipse Juno Editor Tabs [message #896801 is a reply to message #893722] Thu, 19 July 2012 20:56 Go to previous messageGo to next message
Alex Ioannou is currently offline Alex Ioannou
Messages: 1
Registered: July 2012
Junior Member
Did anyone even test the Juno release on KDE? It looks absolutely terrible. What's with all of the white backgrounds and the stupid toolbar shading?
  • Attachment: snapshot1.png
    (Size: 119.95KB, Downloaded 186 times)
Re: Wrong font on Eclipse Juno Editor Tabs [message #896811 is a reply to message #896801] Thu, 19 July 2012 21:46 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5312
Registered: July 2009
Senior Member
Switch to the classic theme if you don't like the new one.

Tom

Am 19.07.12 22:56, schrieb Alex Ioannou:
> Did anyone even test the Juno release on KDE? It looks absolutely terrible. What's with all of the white backgrounds and the stupid toolbar shading?
>
Re: Wrong font on Eclipse Juno Editor Tabs [message #896816 is a reply to message #896811] Thu, 19 July 2012 22:42 Go to previous message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5312
Registered: July 2009
Senior Member
You can try
http://tomsondev.bestsolution.at/2012/07/19/eclipse-4-lf-on-linux/

Tom

Am 19.07.12 23:46, schrieb Tom Schindl:
> Switch to the classic theme if you don't like the new one.
>
> Tom
>
> Am 19.07.12 22:56, schrieb Alex Ioannou:
>> Did anyone even test the Juno release on KDE? It looks absolutely terrible. What's with all of the white backgrounds and the stupid toolbar shading?
>>
>
Previous Topic:SWT browser not working with XULRunner 1.8.x, 1.9.x, 3.6.x, 10.x downloaded from mozilla.org
Next Topic:Table cell, controls as content
Goto Forum:
  


Current Time: Mon Sep 15 09:49:48 GMT 2014

Powered by FUDForum. Page generated in 0.01760 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software