Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Virgo Bundlor released
Virgo Bundlor released [message #892316] Wed, 27 June 2012 13:14 Go to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Virgo Bundlor 1.1.0.RELEASE is available for download (or from the update site listed on the download page). A Bundlor User Guide is also available.
Re: Virgo Bundlor released [message #892761 is a reply to message #892316] Fri, 29 June 2012 10:10 Go to previous messageGo to next message
boris van lietl is currently offline boris van lietl
Messages: 1
Registered: June 2012
Junior Member
Hi,

While trying to build a project with this new version I have the following error :


[ERROR] Invalid plugin descriptor for org.eclipse.virgo.bundlor:org.eclipse.virgo.bundlor.maven:1.1.0.RELEASE (/Users/james/.m2/repository/org/eclipse/virgo/bundlor/org.eclipse.virgo.bundlor.maven/1.1.0.RELEASE/org.eclipse.virgo.bundlor.maven-1.1.0.RELEASE.jar), Plugin's descriptor contains the wrong version: 1.1.0.M05 -> [Help 1]


When unzipping the jar I can see that under META-INF/maven/plugin.xml there is a <version>1.1.0.M05</version> which conflicts with the release version.

I wrote my pom based on this ... eclipse.org/virgo/documentation/bundlor-documentation-1.1.0.RELEASE/docs/user-guide/htmlsingle/user-guide.html#usage.maven

Any hint ? Maybe I'm doing something wrong ..

btw ... I imported the artifact into our internal repo and changed version to 1.1.0.M05 and the following error is ..

Jun 29, 2012 4:07:13 PM org.sonatype.guice.bean.reflect.LoadedClass
WARNING: Error injecting: org.eclipse.virgo.bundlor.maven.plugin.BundlorMojo
java.lang.NoClassDefFoundError: org/eclipse/virgo/bundlor/support/manifestwriter/ManifestWriterFactory

Cheers

-B

Re: Virgo Bundlor released [message #892768 is a reply to message #892761] Fri, 29 June 2012 10:30 Go to previous message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
There is no automated test of the Maven bundlor plugin to pick up that bug. Apologies. I will fix this under bug 383909. To preserve release sanity, this will require a 1.1.1.RELEASE. I'd also better re-run a manual test before publicising the next release.
Previous Topic:Virgo App Profiling/Performance Tuning
Next Topic:ActiveMQ Resolving error
Goto Forum:
  


Current Time: Wed Jul 30 05:26:53 EDT 2014

Powered by FUDForum. Page generated in 0.02311 seconds