Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Zend Debugger Eclipse Startup Error: eclipse.php.debug.core was unable to load class debug.core.mode(Eclipse startup error with zend debugger installed on Mac OSX Lion)
Zend Debugger Eclipse Startup Error: eclipse.php.debug.core was unable to load class debug.core.mode [message #892288] Wed, 27 June 2012 15:32 Go to next message
Manish Gupta is currently offline Manish GuptaFriend
Messages: 1
Registered: June 2012
Junior Member
I work on Mac OSX Lion and ever since I've installed the Zend Debugger and gotten it to be able to debug php web applications, I often encounter this Eclipse startup error:

Error creation extension for extension-point org.eclipse.php.internal.debug.daemon.communication Plug-in org.eclipse.php.debug.core was unable to load class org.eclipse.php.internal.debug.core.zend.communication.DebuggerCommunicationDaemon. An error occurred while automatically activating bundle org.eclipse.php.debug.core (258).


The error log contains the following stack trace:

org.eclipse.debug.core.DebugException: Plug-in org.eclipse.php.debug.core was unable to load class org.eclipse.php.internal.debug.core.model.PHPConditionalBreakpoint.
at org.eclipse.debug.internal.core.BreakpointManager.createBreakpoint(
at org.eclipse.debug.internal.core.BreakpointManager.loadBreakpoints(
at org.eclipse.debug.internal.core.BreakpointManager.initializeBreakpoints(
at org.eclipse.debug.internal.core.BreakpointManager.getBreakpoints0( at org.eclipse.debug.internal.core.BreakpointManager.start(
at org.eclipse.debug.core.DebugPlugin.start(
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$
... Omitted for brevity ...

I've googled for solutions and tried reinstalling eclipse a couple of times. This error only seems to occur if I have both ADT (Android Development Tools) and PDT (PHP Development Tools) + Zend Debugger installed.

Please let me know if you have information about how to solve this problem. On a related note, I never really got the PDT + Zend debugger to work (as in debug) PHP apps on Windows.
Re: Zend Debugger Eclipse Startup Error: eclipse.php.debug.core was unable to load class debug.core. [message #960624 is a reply to message #892288] Sat, 27 October 2012 17:02 Go to previous message
Jacques Singy is currently offline Jacques SingyFriend
Messages: 1
Registered: October 2012
Junior Member
I had the same problem. My error log indicated that eclipse was having trouble setting a breakpoint in my PHP code. I had breakpoints set for PHP as well as java/android code. I removed all my breakpoints, restarted eclipse and the problem went away.
Previous Topic:Adjust whitespace character opacity
Next Topic:Lost when trying to debug PHP
Goto Forum:

Current Time: Sat Nov 28 07:56:59 GMT 2015

Powered by FUDForum. Page generated in 0.02081 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software