Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP 1.5 with Java 7(RAP with Java 7)
RAP 1.5 with Java 7 [message #891751] Mon, 25 June 2012 18:50 Go to next message
Ronald So is currently offline Ronald SoFriend
Messages: 198
Registered: April 2011
Senior Member
Hi,

Is RAP 1.5 RC3 tested with Java 7? I am doing research to make sure that the framework works on Java 7 but I cannot find a confirmation anywhere in the Internet.

Thanks,
Ronald

Re: RAP 1.5 with Java 7 [message #891821 is a reply to message #891751] Tue, 26 June 2012 07:10 Go to previous messageGo to next message
Rüdiger Herrmann is currently offline Rüdiger HerrmannFriend
Messages: 335
Registered: July 2009
Senior Member
Ronald,

RAP requires Java 1.5. In recent releases of the JDK, they tried hard to
stay compatible with previous versions. To spot potential
incompatibilities, I'd recommend to read the JDK migration guide for 1.7
(if there is any).
In addition, compiling RAP against 1.7 and running the test suite might
also reveal incompatibilities.

HTH
Rüdiger

On 25.06.2012 20:50, Ronald So wrote:
> Hi,
>
> Is RAP 1.5 RC3 tested with Java 7? I am doing research to make sure that
> the framework works on Java 7 but I cannot find a confirmation anywhere
> in the Internet.
>
> Thanks,
> Ronald
>
>
--
Rüdiger Herrmann
http://codeaffine.com
Re: RAP 1.5 with Java 7 [message #892630 is a reply to message #891821] Thu, 28 June 2012 20:02 Go to previous messageGo to next message
Ronald So is currently offline Ronald SoFriend
Messages: 198
Registered: April 2011
Senior Member
Thanks Rüdiger. We will find cycles to test and post our results up here.

At the meantime, does anyone of you who are building and running RAP in Java 7?

Thanks,
Ronald
Re: RAP 1.5 with Java 7 [message #895534 is a reply to message #891821] Fri, 13 July 2012 12:54 Go to previous messageGo to next message
Sebastian Kienzl is currently offline Sebastian KienzlFriend
Messages: 9
Registered: July 2012
Junior Member
Hi!

I think it would be a good idea to mention it needs 1.5 somewhere: In release notes or in the getting started guide.

It's probably obvious to many people, but to me it wasn't Smile
E.g. the demos don't run under 1.7.

Regards

[Updated on: Fri, 13 July 2012 12:55]

Report message to a moderator

Re: RAP 1.5 with Java 7 [message #895546 is a reply to message #895534] Fri, 13 July 2012 13:52 Go to previous messageGo to next message
Rüdiger Herrmann is currently offline Rüdiger HerrmannFriend
Messages: 566
Registered: July 2009
Senior Member
Seb,

please see my comments below.

Regards,
Rüdiger

On 13.07.2012 14:54, Seb L wrote:
> Hi!
>
> I think it would be a good idea to mention that somewhere: In release
> notes or in the getting started guide.
As all RAP artifacts are OSGi bundles they carry the minimum required
execution environment in their manifest.
But I agree that I might be worth documenting this elsewhere.

>
> It's probably obvious to many people, but to me it wasn't :)
> E.g. the demos don't run under 1.7.
Please let us know what exactly isn't working, I doubt that Java 1.7
isn't backwards compatible.
What demos do you refer to?
What JDK do you compile against?
What JRE are you running on?
What exactly is the error that you see?
....
A bug report [1] with detailed information to reproduce the issue would
be great.

[1] http://www.eclipse.org/rap/bugs/

>
> Regards
>
--
Rüdiger Herrmann
http://codeaffine.com
Re: RAP 1.5 with Java 7 [message #895584 is a reply to message #895546] Fri, 13 July 2012 16:53 Go to previous message
Sebastian Kienzl is currently offline Sebastian KienzlFriend
Messages: 9
Registered: July 2012
Junior Member
Sure, there you go:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=385074

Regards
Previous Topic:error in firefox!
Next Topic:Browser Title won't change after switching locale
Goto Forum:
  


Current Time: Sun Nov 23 16:23:01 GMT 2014

Powered by FUDForum. Page generated in 0.02734 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software