Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sapphire » Problem while exporting a plugin
Problem while exporting a plugin [message #890033] Wed, 20 June 2012 17:20 Go to next message
Etienne Beaumont is currently offline Etienne BeaumontFriend
Messages: 9
Registered: November 2011
Junior Member
Hello everybody,

While trying to export my Sapphire plugin, I have the following error poping :

E:\USERS\ebeaumon\workspace\.metadata\.plugins\org.eclipse.pde.core\temp\org.eclipse.pde.container.feature\compile.org.eclipse.pde.container.feature.xml:4: The following error occurred while executing this line:
E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\build.xml:328: The following error occurred while executing this line:
E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\build.xml:245: The following error occurred while executing this line:
E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\customBuildCallbacks.xml:54: The following error occurred while executing this line:
E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\customBuildCallbacks.xml:97: Error running apt.exe compiler
The following error occurred while executing this line:
E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\build.xml:328: The following error occurred while executing this line:
E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\build.xml:245: The following error occurred while executing this line:
E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\customBuildCallbacks.xml:54: The following error occurred while executing this line:
E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\customBuildCallbacks.xml:97: Error running apt.exe compiler


Adding <record name="${basedir}/logapt.txt" action="start"/> only gives me :

   [delete] Deleting directory E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\.apt_generated
    [mkdir] Created dir: E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\.apt_generated
      [jar] Building jar: E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\apt-classpath.jar
   [delete] Deleting: E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\apt-classpath.jar.manifest
   [delete] Deleting: E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\apt-factorypath.jar.manifest
      [apt] E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\customBuildCallbacks.xml:97: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
      [apt] Since compiler setting isn't classic or modern, ignoring fork setting.
      [apt] Since compiler setting isn't classic or modern, ignoring fork setting.
      [apt] Compiling 79 source files to E:\USERS\ebeaumon\workspace\SapphireVtXMLEditor\.apt_generated
      [apt] Since compiler setting isn't classic or modern, ignoring fork setting.


I also tried to export the sapphire.samples, and had the same error, so I guess it is probably a configuration problem.

(I read the [message #762110] and I have no spaces in my eclipse path)

Do you know what to do to have more information on the apt error?

I tried everything I had in mind but I am far from being an expert in APT...

Thank you very much,

Etienne

[Updated on: Wed, 20 June 2012 17:21]

Report message to a moderator

Re: Problem while exporting a plugin [message #890059 is a reply to message #890033] Wed, 20 June 2012 21:15 Go to previous messageGo to next message
Konstantin Komissarchik is currently offline Konstantin KomissarchikFriend
Messages: 962
Registered: July 2009
Senior Member
Etienne,

This issue could be caused by running the Ant script with a JRE as opposed to a JDK install. A JRE install does not contain apt.

The PDE export wizards re-use the JRE/JDK that Eclipse itself is running with when launching the Ant script.

To try to resolve this, edit your eclipse.ini file and add the following two lines at the very beginning:

-vm
[path within a JDK install]\jvm.dll

- Konstantin
Re: Problem while exporting a plugin [message #890192 is a reply to message #890059] Thu, 21 June 2012 12:16 Go to previous message
Etienne Beaumont is currently offline Etienne BeaumontFriend
Messages: 9
Registered: November 2011
Junior Member
It worked but failed a little later - probably incompatibilities between Sapphire 0.4 and 0.5, both were installed in a very messy way.

I did a clean install of eclipse (with jdk + Eclipse EE) and the sapphire part works now (I still have problems with exporting the FOP pdf generator).

Thanks for this answer, thanks for your support, and thanks for the project. Smile

Etienne

[Updated on: Thu, 21 June 2012 12:16]

Report message to a moderator

Previous Topic:XML files with missing namespace/schema
Next Topic:Announcing Sapphire 0.5 Release
Goto Forum:
  


Current Time: Fri Dec 19 10:22:27 GMT 2014

Powered by FUDForum. Page generated in 0.01896 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software