Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Filters in package and project explorer broken?
Filters in package and project explorer broken? [message #889877] Wed, 20 June 2012 06:37 Go to next message
Marcel Bruch is currently offline Marcel Bruch
Messages: 230
Registered: July 2009
Senior Member
I'm not yet sure if it's a bug or some misunderstanding on my end.

I created a new plug-in project from an existing jar. Problem: Classes in this jar are properly imported (as can be seen in the navigator view) but cannot be referenced nor do they show up in the Project/Package Explorer (all filters disabled as shown on the screenshot). Do I miss something obvious?

Thanks,
Marcel

index.php/fa/10355/0/


tw: @MarcelBruch
tw: @Recommenders
Re: Filters in package and project explorer broken? [message #889968 is a reply to message #889877] Wed, 20 June 2012 12:44 Go to previous messageGo to next message
Deepak Azad is currently offline Deepak Azad
Messages: 545
Registered: July 2009
Senior Member
Can you check if the classes are inside a source folder OR in other
words they are on the build path or not ?

--
Deepak Azad
http://wiki.eclipse.org/JDT/FAQ
Re: Filters in package and project explorer broken? [message #889973 is a reply to message #889968] Wed, 20 June 2012 12:59 Go to previous message
Marcel Bruch is currently offline Marcel Bruch
Messages: 230
Registered: July 2009
Senior Member
Right. .classpath contained '/' as src path. Then this was a misunderstanding on my end. Although I'm not sure why the wizard generates these entries as they don't make sense to me. Anyways, thanks.


<classpath>
<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path=""/>
<classpathentry kind="output" path="bin"/>
</classpath>


tw: @MarcelBruch
tw: @Recommenders
Previous Topic:problem to connetc to marketplace on indivo realese 2
Next Topic:Could not initialize class org.eclipse.xsd.XS
Goto Forum:
  


Current Time: Fri Oct 24 20:45:28 GMT 2014

Powered by FUDForum. Page generated in 0.01554 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software