Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Unable to install PDT on Ubuntu 12.04
Unable to install PDT on Ubuntu 12.04 [message #889644] Tue, 19 June 2012 12:42 Go to next message
William Farmer is currently offline William Farmer
Messages: 1
Registered: June 2012
Junior Member
I am running Ubuntu 12.04

In the Eclipse IDE, I am unable to install PDT via
Help -> Install New Software

Cannot complete the install because of a conflicting dependency.
  Software being installed: PDT Feature 1.0.5.v20081126-1856 (org.eclipse.php_feature.feature.group 1.0.5.v20081126-1856)
  Software currently installed: Eclipse Platform 3.7.0.I20110613-1736 (org.eclipse.platform.ide 3.7.0.I20110613-1736)
  Only one of the following can be installed at once: 
    International Components for Unicode for Java (ICU4J) 4.4.2.v20110208 (com.ibm.icu 4.4.2.v20110208)
    International Components for Unicode for Java (ICU4J) 4.4.2.v20110823 (com.ibm.icu 4.4.2.v20110823)
    International Components for Unicode for Java (ICU4J) 3.8.1.v20080530 (com.ibm.icu 3.8.1.v20080530)
    International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
    International Components for Unicode for Java (ICU4J) 4.0.1.v20090415 (com.ibm.icu 4.0.1.v20090415)
  Cannot satisfy dependency:
    From: PDT Feature 1.0.5.v20081126-1856 (org.eclipse.php_feature.feature.group 1.0.5.v20081126-1856)
    To: org.eclipse.wst.feature.group [3.0.0,4.0.0)
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.2.dist-9nF7UHagFqn9pElwWhC90gLz-soEuSGYmtSeiRH (org.eclipse.platform.feature.group 3.7.2.dist-9nF7UHagFqn9pElwWhC90gLz-soEuSGYmtSeiRH)
    To: org.eclipse.rcp.feature.group [3.7.2.dist-8R9GFpOFUdy-521934]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.0.I20110613-1736 (org.eclipse.platform.ide 3.7.0.I20110613-1736)
    To: org.eclipse.platform.feature.group [3.7.2.dist-9nF7UHagFqn9pElwWhC90gLz-soEuSGYmtSeiRH]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.7.2.dist-8R9GFpOFUdy-521934 (org.eclipse.rcp.feature.group 3.7.2.dist-8R9GFpOFUdy-521934)
    To: com.ibm.icu [4.4.2.v20110823]
  Cannot satisfy dependency:
    From: Web Developer Tools 3.0.4.v200811190840-7A-8l8Qqcz0HyVgjXUE-iuOYZ9ai (org.eclipse.wst.feature.group 3.0.4.v200811190840-7A-8l8Qqcz0HyVgjXUE-iuOYZ9ai)
    To: org.eclipse.wst.jsdt.feature.feature.group [1.0.4.v200812112112-6-E75BcMAAyDJGhFpNN]
  Cannot satisfy dependency:
    From: JavaScript Development Tools Core 1.0.104.v200901281939 (org.eclipse.wst.jsdt.core 1.0.104.v200901281939)
    To: bundle com.ibm.icu [3.8.1,4.0.0)
  Cannot satisfy dependency:
    From: JavaScript Developer Tools 1.0.4.v200812112112-6-E75BcMAAyDJGhFpNN (org.eclipse.wst.jsdt.feature.feature.group 1.0.4.v200812112112-6-E75BcMAAyDJGhFpNN)
    To: org.eclipse.wst.jsdt.core [1.0.104.v200901281939]


I have no idea what to do or how to get PDT installed. I have Eclipse installed via the software package manager and have tried to install it via the command line but it never worked.

I've done searches for sections of this error message and never got anywhere.

So, I'd like to find some way of getting PDT installed through the Install New Software part of eclipse.

Thanks!
Re: Unable to install PDT on Ubuntu 12.04 [message #889887 is a reply to message #889644] Wed, 20 June 2012 07:25 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 351
Registered: July 2009
Location: Japan
Senior Member
I've made following steps.
1) Install Ubuntu 12.04.
2) Start 'Ubuntu Software Center' and install 'Eclipse'.[*]
3) Start Eclipse and install PDT via Help>Install New Software>Indigo Update Site.
No problem here.
I cannot see any difficulties.

>Software being installed: PDT Feature 1.0.5.v20081126-1856 (org.eclipse.php_feature.feature.group 1.0.5.v20081126-1856)
Can you elaborate the reason why you need such an old version? 1.0.5 which was released in ancient era doesn't work in this era 2012.
Never use http://download.eclipse.org/tools/pdt/updates/ since it is not for nowadays. You must select Indigo Update Site.

[*] Installing Eclipse from ubuntu repository via Ubuntu Software Center or Synaptic Package Manager or apt-get command or so is *not* recommended.
Re: Unable to install PDT on Ubuntu 12.04 [message #896302 is a reply to message #889644] Tue, 17 July 2012 23:10 Go to previous message
Jeff Brewster is currently offline Jeff Brewster
Messages: 1
Registered: July 2012
Junior Member
What version of Eclipse? (Juno? Indigo?)

What URL did you use (it matters what repository you use, depending on the version of Eclipse you have)?
I have had it (PDT install to Juno) fail on my Ubuntu (11.04, 12.04) and Mac (10.6.Cool but it worked on Windows (I wish I remember what I did! I remember it was easy).

http://download.eclipse.org/tools/pdt/updates ?

or ...

I tried everything and finally found that this indigo repository seemed pretty up-to-date (I am sure I overlooked this before because I am on Juno). Decided to give it a try...

http://download.eclipse.org/releases/indigo/

It works! Very Happy

I think after the first (Windows) install where I probably just Googled "PDT Eclipse" and installed the first thing that came up, I began over-thinking the process and looking for "Juno" repositories (that apparently don't exist yet).

Cheers.

Previous Topic:Help please - PDT Setup questions
Next Topic:PHP+Apachi with eclipse - work it???
Goto Forum:
  


Current Time: Thu Oct 23 00:55:32 GMT 2014

Powered by FUDForum. Page generated in 0.01601 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software