Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Updating fails 4.2.0 - I20120315-1300 [SOLVED -THANKS]
icon14.gif  Updating fails 4.2.0 - I20120315-1300 [SOLVED -THANKS] [message #887903] Sun, 17 June 2012 10:33 Go to next message
Ruben Goethals is currently offline Ruben GoethalsFriend
Messages: 11
Registered: November 2009
Junior Member
I am trying to update from 4.2.0 - I20120315-1300 to the latest milestone (or stable build). I just pressed Help -> Search for updates, then I get a loading window and then I get "Available updates" window. In there it says "Operation cannot be completed. See details". Details below. Anyone any idea how to solve this? Thanks!


Details:
Cannot complete the install because of a conflicting dependency.
Software being installed: JavaScript Development Tools 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4 (org.eclipse.wst.jsdt.feature.feature.group 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4)
Software currently installed: Eclipse Web Developer Tools 3.4.0.v201203141800-7O7MFsHEMjBJz0oJYmfGe1NecX-eibdJmMHb7w0y (org.eclipse.wst.web_ui.feature.feature.group 3.4.0.v201203141800-7O7MFsHEMjBJz0oJYmfGe1NecX-eibdJmMHb7w0y)
Only one of the following can be installed at once:
JavaScript Development Tools 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4 (org.eclipse.wst.jsdt.feature.feature.jar 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4)
JavaScript Development Tools 1.4.0.v201111090639-7G7DFciFC7sRelSOcldK09 (org.eclipse.wst.jsdt.feature.feature.jar 1.4.0.v201111090639-7G7DFciFC7sRelSOcldK09)
Cannot satisfy dependency:
From: JavaScript Development Tools 1.4.0.v201111090639-7G7DFciFC7sRelSOcldK09 (org.eclipse.wst.jsdt.feature.feature.group 1.4.0.v201111090639-7G7DFciFC7sRelSOcldK09)
To: org.eclipse.wst.jsdt.feature.feature.jar [1.4.0.v201111090639-7G7DFciFC7sRelSOcldK09]
Cannot satisfy dependency:
From: JavaScript Development Tools 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4 (org.eclipse.wst.jsdt.feature.feature.group 1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4)
To: org.eclipse.wst.jsdt.feature.feature.jar [1.4.0.v201111090639-7H7DFeHFC7sRemSZgYbe4]
Cannot satisfy dependency:
From: Eclipse Web Developer Tools 3.4.0.v201203141800-7O7MFsHEMjBJz0oJYmfGe1NecX-eibdJmMHb7w0y (org.eclipse.wst.web_ui.feature.feature.group 3.4.0.v201203141800-7O7MFsHEMjBJz0oJYmfGe1NecX-eibdJmMHb7w0y)
To: org.eclipse.wst.jsdt.feature.feature.group [1.4.0.v201111090639-7G7DFciFC7sRelSOcldK09]


[Updated on: Sun, 24 June 2012 15:05]

Report message to a moderator

Re: Updating fails 4.2.0 - I20120315-1300 [message #891242 is a reply to message #887903] Sun, 24 June 2012 12:11 Go to previous messageGo to next message
Ruben Goethals is currently offline Ruben GoethalsFriend
Messages: 11
Registered: November 2009
Junior Member
Anyone? Even if some tips in how to find this myself? I've read some similar forum topics, but no help so far.
Thanks for any insights or suggestions!


Re: Updating fails 4.2.0 - I20120315-1300 [message #891272 is a reply to message #891242] Sun, 24 June 2012 14:13 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 242
Registered: July 2009
Senior Member
Deciphering p2's messages is a bit of an art! It looks like you explicitly installed a version of JSDT that conflicts with the version required by WDT. Try uninstalling JSDT (it will still be present, since it's required by WDT which you'll still have installed) and then try updating again.

[Updated on: Sun, 24 June 2012 14:13]

Report message to a moderator

Re: Updating fails 4.2.0 - I20120315-1300 [message #891274 is a reply to message #891272] Sun, 24 June 2012 14:15 Go to previous messageGo to next message
Neeraj Bhusare is currently offline Neeraj BhusareFriend
Messages: 93
Registered: July 2009
Location: India
Member
Can you try uninstalling some of these plugins (Help->Installation details->Installed software tab) and then reinstalling the latest plugins (if one exists). Hope this helps.

Best regards, Neeraj
Re: Updating fails 4.2.0 - I20120315-1300 [message #891285 is a reply to message #891274] Sun, 24 June 2012 15:04 Go to previous message
Ruben Goethals is currently offline Ruben GoethalsFriend
Messages: 11
Registered: November 2009
Junior Member
@Brian de Alwis: Thanks! I did what you proposed, and thoug I got the exact same error but for "org.eclipse.wst.xml.ui 1.1.300", so I risked completely uninstalling "Eclipse XML Editors and Tools" and after that the update worked!
I checked and JSDT is not back (but still in WDT as you said) and dunno why but "Eclipse XML Editors and Tools" is there again too!
*sweatwipe* Never had such troubles with Eclipse update before! Glad I al over it! Thanks again! If I can return the favor any way, let me know.

@Neeraj: Thanks too! Although I didn't find (Help->Installation details->Installed software tab) and where I found installed plugins there was no single uninstall feature, thanks for also answering, and maybe it gived me that extra push to uninstall Editors & Tools above (which I found risky).


Previous Topic:SplashHandler / interactive splash screen
Next Topic:Ignore CSS for some Widgets
Goto Forum:
  


Current Time: Sun Nov 23 22:48:59 GMT 2014

Powered by FUDForum. Page generated in 0.01681 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software