Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse plugins for Eclipse 4(Issue faced in migration from eclipse 3.5.2 to eclipse 4.1.2)
Eclipse plugins for Eclipse 4 [message #886610] Fri, 15 June 2012 09:28 Go to next message
Rohan Kapur is currently offline Rohan KapurFriend
Messages: 6
Registered: October 2010
Junior Member
Hi All,

We have used the following plugins and created a workbench of our own.
Eclipse Data Tool Platform (DTP)
Eclipse Modeling Framework (EMF)
Eclipse Graphical Editing Framework (GEF)
Eclipse Java Development Tools (JDT)
Eclipse JEM
Eclipse Plugin Development Environment (PDE)
Eclipse Web Tools Platform (WTP)
Eclipse XSD
Eclipse Platform Runtime Binary

The versions required of the above pakcages are made available in the download page of eclipse 3.5.2.We download the individual packages unzip them and create our workbench.

Currently we are using eclipse platform version 3.5.2 and since we are moving to Java 7, we needed to upgrade the platform to Eclipse 4.1.2.

Now when I go to the download page of eclipse 4.1.2 I do not find the required packages. All I get are the links to download the SDK for different environments.

Could someone please let me know the steps to migrate in my scenario.
Re: Eclipse plugins for Eclipse 4 [message #886803 is a reply to message #886610] Fri, 15 June 2012 16:56 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Eclipse Juno (based on 4.2) will be out in about a week. But if you want to go head now, don't look at 4.1.2. Use Indigo. You want Eclipse Classic 3.7.2 and then install your packages from http://download.eclipse.org/release/indigo

If you wait until next week, then you would want Eclipse Classic 4.2.0 and install your other packages from http://download.eclipse.org/releases/juno ... for this week, though, there's only testing data available for Juno.

PW


Previous Topic:How to create a view at startup
Next Topic:3.x plugins provided with the support of CSS in Eclipse 4?
Goto Forum:
  


Current Time: Sun Dec 21 00:33:10 GMT 2014

Powered by FUDForum. Page generated in 0.02048 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software