Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » org.eclipse.mylyn plugin required for Rally connector but cannot be installed with p2.director
org.eclipse.mylyn plugin required for Rally connector but cannot be installed with p2.director [message #885931] Wed, 13 June 2012 22:09 Go to next message
Jason Bodnar is currently offline Jason Bodnar
Messages: 1
Registered: June 2012
Junior Member
I'm trying to write a script that will install our companies developer environment (including Eclipse and various plugins).

I'm able to install several Mylyn feature groups from the script using p2.director. I also want to install the Rally connector for Mylyn. When I try to do so I get:

Software being installed: Rally Mylyn Connector 1.5.10 (com.rallydev.mylyn_feature.feature.group 1.5.10)
  Missing requirement: Rally Mylyn Connector 1.5.10 (com.rallydev.mylyn_feature.feature.group 1.5.10) requires 'org.eclipse.mylyn [3.4.0,4.0.0)' but it could not be found


I get the same error if I try to install from the Eclipse UI if I don't check "Contact all update sites during install to find required software"

If I do check it the Rally Mylyn Connector installs yet there is no org.eclipse.mylyn_[version #].jar in the plugins director nor does the About Eclipse dialog show any additional Mylyn features.

What do I need to install from my script to satisfy this dependency? If the Eclipse UI installer recognizes it as a dependency and can fulfill it surely there must be a way to do it with p2.director.

[Updated on: Thu, 14 June 2012 18:32]

Report message to a moderator

Re: org.eclipse.mylyn plugin required for Rally connector but cannot be installed with p2.director [message #895551 is a reply to message #885931] Fri, 13 July 2012 13:59 Go to previous message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
If you are using Mylyn 3.7 or later you will need to get the latest 1.5.11
version of the Rally connector. That version does no longer depend on the
org.eclipse.mylyn bundle which was removed from Mylyn.

Please let us know if it's still failing with the latest version.

Steffen


Jason Bodnar wrote:

> I'm trying to write a script that will install our companies developer
> environment (including Eclipse and various plugins).
>
> I'm able to install several Mylyn feature groups from the script using
> p2.director. I also want to install the Rally connector for Mylyn. When I
> try to do so I get:
>
> Software being installed: Rally Mylyn Connector 1.5.10
> (com.rallydev.mylyn_feature.feature.group 1.5.10)
> Missing requirement: Rally Mylyn Connector 1.5.10
> (com.rallydev.mylyn_feature.feature.group 1.5.10) requires
> 'org.eclipse.mylyn [3.4.0,4.0.0)' but it could not be found
>
> I get the same error if I try to install from the Eclipse UI if I don't
> check "Contact all update sites during install to find required software"
>
> If I do check it the Rally Mylyn Connector installs yet there is no
> org.eclipse.mylyn_[version #].jar in the plugins director nor does the
> About Eclipse dialog show any additional Mylyn features.
>
> What do I need to install from my script to satisfy this dependency? If
> the Eclipse UI installer recognizes it as a dependency and can fulfil it
> surely there must be a way to do it with p2.director.
--
Steffen Pingel
Committer, http://eclipse.org/mylyn
Senior Developer, http://tasktop.com
Previous Topic:Question on Mylyn usage
Next Topic:Where does "New Comment" go in the Rally connector?
Goto Forum:
  


Current Time: Thu Oct 23 12:27:27 GMT 2014

Powered by FUDForum. Page generated in 0.01679 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software