Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Java Perspective disappeared(when I updated what was installed)
icon9.gif  Java Perspective disappeared [message #885202] Tue, 12 June 2012 15:46 Go to next message
Mary-Anne Wolf is currently offline Mary-Anne Wolf
Messages: 2
Registered: June 2012
Junior Member
I am running Eclipse Indigo on 64 bit Kubunu Linux.
I start with the version that is installed by the package manager
using root access,
but most of the time I run Eclipse as non-root, including installing updates.
I tried installing updates and after I restarted
my Java perspective went away.
I tried to get the Marketplace client to appear by manually installing it
and it also did not appear.
I tried running Eclipse from the command-line and there was no output.
I have looked for a log in my home directory and not found one.
I have tried eclipse -clean. No difference.
The only perspectives I have now are <Java> (which is not the Java perspectiv)
and Resource.
I tried
eclipse -consolelog -debug
Start VM: /usr/lib/jvm/java-7-openjdk-amd64/bin/java
-Djava.library.path=/usr/lib/jni
-Xms40m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:MaxPermSize=256m
-jar /usr/lib/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.dist.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.dist/eclipse_1408.so
-startup /usr/lib/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.dist.jar
--launcher.overrideVmargs
-exitdata 209802d
-consolelog
-debug
-vm /usr/lib/jvm/java-7-openjdk-amd64/bin/java
-vmargs
-Djava.library.path=/usr/lib/jni
-Xms40m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:MaxPermSize=256m
-jar /usr/lib/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.dist.jar
Install location:
file:/usr/lib/eclipse/
Configuration file:
file:/usr/lib/eclipse/configuration/config.ini loaded
Configuration location:
file:/home/marwolf/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/
Configuration file:
file:/home/marwolf/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/config.ini loaded
Shared configuration location:
file:/usr/lib/eclipse/configuration/
Framework located:
file:/usr/lib/eclipse/plugins/org.eclipse.osgi_3.7.2.dist.jar
Framework classpath:
file:/usr/lib/eclipse/plugins/org.eclipse.osgi_3.7.2.dist.jar
Splash location:
/usr/lib/eclipse/plugins/org.eclipse.platform_3.7.2.dist/splash.bmp
Debug options:
file:/home/marwolf/.options not found
Time to load bundles: 3
Starting application: 2699
Application Started: 7771

I have repeatedly tried moving ~/.eclipse and workspace and starting again
which fixes things temporarily but of course I have to reinstall everything.
This has happened multiple times and I would really like to figure out
how to fix it or avoid it.

How do I determine what the problem is?

Thanks.



[Updated on: Tue, 12 June 2012 15:51]

Report message to a moderator

Re: Java Perspective disappeared [message #885501 is a reply to message #885202] Wed, 13 June 2012 06:07 Go to previous messageGo to next message
Satyam Kandula is currently offline Satyam Kandula
Messages: 444
Registered: July 2009
Senior Member
Look for the .log file in <workspace>/.metadata directory. It could contain some information.
Re: Java Perspective disappeared [message #886190 is a reply to message #885501] Thu, 14 June 2012 12:05 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan Herrmann
Messages: 1024
Registered: July 2009
Senior Member
If you have read-only access to your Eclipse installation, installing new software should work alright but some update-operations are actually supposed to fail, since this setup is intended for cases where an admin forces you to use a specific version / configuration of Eclipse. So, yes, looking for errors in the workspace log might give hints on the failed update.

If lock-down of a specific Eclipse version is not intended installation as root is actually questionable. There should be no need to install as root. So if you want the exact version that is packaged for Ubuntu, you may prefer to stick to that version. If, OTOH, you want to update at your own pace, you will be better off directly downloading and installing from Eclipse.org using your regular user account.

HTH,
Stephan
icon9.gif  Re: Java Perspective disappeared [message #886827] Fri, 15 June 2012 17:44 Go to previous message
Mary-Anne Wolf is currently offline Mary-Anne Wolf
Messages: 2
Registered: June 2012
Junior Member
Thanks for the help but never mind.
I just lost the job where I was working on this.

Mary-Anne
Previous Topic:Resolve generic type in subclass?
Next Topic:Console input encoding
Goto Forum:
  


Current Time: Sun Oct 26 01:15:04 GMT 2014

Powered by FUDForum. Page generated in 0.01728 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software