Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Memory Analyzer » Some Paths to GC root not found?(Some Paths to GC root not found?)
Some Paths to GC root not found? [message #878367] Tue, 29 May 2012 06:48 Go to next message
Xavier Appe is currently offline Xavier AppeFriend
Messages: 2
Registered: May 2012
Junior Member
Hi,

When using MAT 1.1.1 with Eclipse, I encountered the following problem:
One of the GC root reference is not found when clicking on

www.pics-web.com/images/gcroot1.png
(This forum does not allow me to insert image until I creates 25 messages)

I get

www.pics-web.com/images/gcroot2.png

But the reference to the firstTimer is not mentionned!

www.pics-web.com/images/gcroot3.png

Is this a bug or am I doing something wrong?

Thank you

Best regards,

Xavier Appe
Re: Some Paths to GC root not found? [message #878976 is a reply to message #878367] Wed, 30 May 2012 09:45 Go to previous messageGo to next message
Andrew Johnson is currently offline Andrew JohnsonFriend
Messages: 123
Registered: July 2009
Senior Member
The images again:
>One of the GC root reference is not found when clicking on
http://www.pics-web.com/images/gcroot1.png
>I get
http://www.pics-web.com/images/gcroot2.png
>But the reference to the firstTimer is not mentionned!
http://www.pics-web.com/images/gcroot3.png

Did you click on 'Fetch Next Paths'?

There is a similar bug report Bugzilla 371642: Path To GC Roots gives incomplete information where it appears that the query only shows the shortest paths. For example if A>B>C and A>C then it won't show the path to roots from C back to B.
Does the explanation in the bug help?


Re: Some Paths to GC root not found? [message #879356 is a reply to message #878976] Thu, 31 May 2012 03:33 Go to previous message
Xavier Appe is currently offline Xavier AppeFriend
Messages: 2
Registered: May 2012
Junior Member
Hi Andrew,

Thank you for your answer.

I clicked on 'Fetch Next Paths' until no more paths left (see below)

www.pics-web.com/images/gcroot4.png

I couldn't find the reference to firstTimer but it really looks like the bug mentionned above: 371642.
It looks like we have DealNotifyTable->...->firstTimer->...->AppContext and DealNotifyTable->...->AppContext

www.pics-web.com/images/gcroot5.png

Hope we can have a fix soon, because otherwise it is very useful tool!

Best regards,

Xavier Appe

[Updated on: Thu, 31 May 2012 03:34]

Report message to a moderator

Previous Topic:java.lang.NoClassDefFoundError: org/eclipse/mat/ui/snapshot/editor/ISnapshotEditorInput
Next Topic:No way to run the MAT
Goto Forum:
  


Current Time: Sun Dec 21 06:18:31 GMT 2014

Powered by FUDForum. Page generated in 0.14027 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software