Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » buckminster 3.7 + subclipse 1.8.x is NOT compatible.
buckminster 3.7 + subclipse 1.8.x is NOT compatible. [message #876262] Thu, 24 May 2012 09:02 Go to next message
Minhyuk Kwon is currently offline Minhyuk Kwon
Messages: 4
Registered: January 2012
Junior Member
I got a Error Message like this:

D:\Indigo_3.7.2\configuration\org.eclipse.osgi\bundles\357\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:277: java.lang.NoSuchMethodError: org.tigris.subversion.subclipse.core.SVNClientManager.createSVNClient()Lorg/tigris/subversion/svnclientadapter/ISVNClientAdapter;


this situation occur these setting:
Buckminster 3.7 with Subclipse 1.8.x in Indigo SR2 for RCP developer.

I was downgrade subclipse to 1.6.x, everythings fine.

What's I missing?


Regards,

-Minhyuk Kwon
Re: buckminster 3.7 + subclipse 1.8.x is NOT compatible. [message #876283 is a reply to message #876262] Thu, 24 May 2012 09:52 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
This is intentional since Subclipse dropped support for SVNKit in 1.8. That's a change that is too intrusive for us to
include in a service release.

The upgrade to Subclipse 1.8 has been made in the Buckminster Juno release.

Regards,
Thomas Hallgren

On 05/24/2012 11:02 AM, Minhyuk Kwon wrote:
> I got a Error Message like this:
>
> D:\Indigo_3.7.2\configuration\org.eclipse.osgi\bundles\357\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:277:
> java.lang.NoSuchMethodError:
> org.tigris.subversion.subclipse.core.SVNClientManager.createSVNClient()Lorg/tigris/subversion/svnclientadapter/ISVNClientAdapter;
>
>
>
> this situation occur these setting:
> Buckminster 3.7 with Subclipse 1.8.x in Indigo SR2 for RCP developer.
> I was downgrade subclipse to 1.6.x, everythings fine.
>
> What's I missing?
>
>
> Regards,
>
> -Minhyuk Kwon
>
Re: buckminster 3.7 + subclipse 1.8.x is NOT compatible. [message #880567 is a reply to message #876283] Sat, 02 June 2012 09:53 Go to previous messageGo to next message
Eclipse User
Hello, we are facing the same problem and we are willing to switch to
Juno RC2, but where can we find the matching Buckminster version.
Is there any update site or zip file available.

Regards,
Roland Laqua

Am 24.05.2012 11:52, schrieb Thomas Hallgren:
> This is intentional since Subclipse dropped support for SVNKit in 1.8.
> That's a change that is too intrusive for us to include in a service
> release.
>
> The upgrade to Subclipse 1.8 has been made in the Buckminster Juno release.
>
> Regards,
> Thomas Hallgren
>
> On 05/24/2012 11:02 AM, Minhyuk Kwon wrote:
>> I got a Error Message like this:
>>
>> D:\Indigo_3.7.2\configuration\org.eclipse.osgi\bundles\357\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:277:
>>
>> java.lang.NoSuchMethodError:
>> org.tigris.subversion.subclipse.core.SVNClientManager.createSVNClient()Lorg/tigris/subversion/svnclientadapter/ISVNClientAdapter;
>>
>>
>>
>>
>> this situation occur these setting:
>> Buckminster 3.7 with Subclipse 1.8.x in Indigo SR2 for RCP developer.
>> I was downgrade subclipse to 1.6.x, everythings fine.
>>
>> What's I missing?
>>
>>
>> Regards,
>>
>> -Minhyuk Kwon
>>
>
Re: buckminster 3.7 + subclipse 1.8.x is NOT compatible. [message #880875 is a reply to message #880567] Sun, 03 June 2012 08:02 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
Hi Roland,

You will find the latest Buckminster build for Juno (currently RC3) here:

http://download.eclipse.org/tools/buckminster/updates-4.2
http://download.eclipse.org/tools/buckminster/headless-4.2

Regards,
Thomas Hallgren


On 06/02/2012 11:53 AM, Roland Laqua wrote:
> Hello, we are facing the same problem and we are willing to switch to Juno RC2, but where can we find the matching
> Buckminster version.
> Is there any update site or zip file available.
>
> Regards,
> Roland Laqua
>
> Am 24.05.2012 11:52, schrieb Thomas Hallgren:
>> This is intentional since Subclipse dropped support for SVNKit in 1.8.
>> That's a change that is too intrusive for us to include in a service
>> release.
>>
>> The upgrade to Subclipse 1.8 has been made in the Buckminster Juno release.
>>
>> Regards,
>> Thomas Hallgren
>>
>> On 05/24/2012 11:02 AM, Minhyuk Kwon wrote:
>>> I got a Error Message like this:
>>>
>>> D:\Indigo_3.7.2\configuration\org.eclipse.osgi\bundles\357\1\.cp\org\eclipse\buckminster\pde\antscripts\build.xml:277:
>>>
>>> java.lang.NoSuchMethodError:
>>> org.tigris.subversion.subclipse.core.SVNClientManager.createSVNClient()Lorg/tigris/subversion/svnclientadapter/ISVNClientAdapter;
>>>
>>>
>>>
>>>
>>>
>>> this situation occur these setting:
>>> Buckminster 3.7 with Subclipse 1.8.x in Indigo SR2 for RCP developer.
>>> I was downgrade subclipse to 1.6.x, everythings fine.
>>>
>>> What's I missing?
>>>
>>>
>>> Regards,
>>>
>>> -Minhyuk Kwon
>>>
>>
>
Re: buckminster 3.7 + subclipse 1.8.x is NOT compatible. [message #881789 is a reply to message #880875] Tue, 05 June 2012 09:03 Go to previous message
Dennis Huebner is currently offline Dennis Huebner
Messages: 208
Registered: July 2009
Senior Member

Hi Thomas,
more and more people are switching to Juno. Even I was already asked twice about the juno compatible p2 repository. Smile
So you should probably list this links on http://www.eclipse.org/buckminster/downloads.html

Best regards,
Dennis.


Previous Topic:ERROR [0016] : java.lang.ArrayIndexOutOfBoundsException: -1
Next Topic:creating a repository keeping all the versions
Goto Forum:
  


Current Time: Tue Sep 16 07:40:29 GMT 2014

Powered by FUDForum. Page generated in 0.01692 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software