Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Mac JRE and classpath settings
Mac JRE and classpath settings [message #876084] Wed, 23 May 2012 17:58 Go to next message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
Hi all,

Sorry for all of the setup related questions, but I am having difficulty getting any of the example test setups working. Probably something obvious I'm missing here.

I'm using the Standalone v. 1.2.0 install on a Mac. What it looks like is that there aren't actually any examples built for the Mac.

Here's what I've tried:

1. Import and open the projects as specified in manual.
2. Start the embedded AUT agent. (e.g. port 60000)
3. Select an item on the "Start AUT" toolbar menu that looks appropriate for my machine...

3a. If I select SimpleAdder2 localhost_system_jre, I get:

5009: AUT start failed
The JAR given as an AUT-classpath is invalid.
Correct these data in the AUT configuration.

I can't find anywhere to set that classpath in preferences.

3b. If I select SimpleAdder2 localhost_gd_installed_jre, I get:

5009: AUT start failed
No valid Java binary found. Check given JRE binary.

There also doesn't seem to be anywhere to set the binary under preferences.


3c. If I select SimpleAdderHTML, nothing happens.

In all cases the progress bar continues to run after the error with "Starting AUT with ID". (I've opened a mino bug on that.)

Is the issue simply that I need to do custom builds and configurations in order to run these examples? (In which case it's likely to be more straightforward to just start form scratch.)

thanks!

Miles
Re: Mac JRE and classpath settings [message #878546 is a reply to message #876084] Tue, 29 May 2012 10:00 Go to previous message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1092
Registered: July 2009
Senior Member
Hi,

It sounds like you're running into this issue. I'm not sure whether the AUTs are startable on Mac (and therefore just the configurations need to be adapted) or whether they are not built for / compatible with Mac at the moment. You could try starting them by hand to see if any of them (SimpleAdder, DVDTool etc) work. If they do, then you would just need to adapt the AUT configurations.

HTH,
Alex
Previous Topic:Can't import sample projects..
Next Topic:Problems using keyboard layout on Swing->RCP
Goto Forum:
  


Current Time: Mon Jul 28 12:28:22 EDT 2014

Powered by FUDForum. Page generated in 0.01554 seconds