Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Problem Running jubula tests with ant. No suitable driver found error(Problem Running jubula tests with ant. No suitable driver found error)
Problem Running jubula tests with ant. No suitable driver found error [message #875327] Tue, 22 May 2012 14:34 Go to next message
Mujibur Rahman is currently offline Mujibur Rahman
Messages: 3
Registered: April 2012
Location: Bangalore
Junior Member
Hello,

I'm working on ant script to run the jubula tests in windows. I could able to run the tests command line but not able to run the ant script. It is throwing the Problem :: No suitable driver found error

Buildfile: build.xml

test:
[exec] Tue May 22 18:15:16 IST 2012 AUT Agent: Connecting to "localhost:60000" ...
[exec] Tue May 22 18:15:17 IST 2012 AUT Agent: connection established.
[exec] Tue May 22 18:15:17 IST 2012 Database: Connecting as "sa" to "jdbc:h2:~/.jubula/database/embedded;MVCC=TRUE;AUTO_SERVER=TRUE;DB_CLOSE_O
N_EXIT=FALSE"...
[exec] [EL Severe]: 2012-05-22 18:15:21.593--ServerSession(15164472)--Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.3.2.v20111125-r10461):
org.eclipse.persistence.exceptions.DatabaseException
[exec] Internal Exception: java.sql.SQLException: No suitable driver found for jdbc:h2:~/.jubula/database/embedded;MVCC=TRUE;AUTO_SERVER=TRUE;DB_CLOSE_ON_E
XIT=FALSE
[exec] Error Code: 0
[exec] !!Error occurred !!
[exec] Database connection failed because of invalid or missing database detail
[exec] Tue May 22 18:15:21 IST 2012 AUT Agent: connection closed.
[exec] Tue May 22 18:15:21 IST 2012 Exit: Code 1

BUILD FAILED
Re: Problem Running jubula tests with ant. No suitable driver found error [message #875329 is a reply to message #875327] Tue, 22 May 2012 14:35 Go to previous messageGo to next message
Mujibur Rahman is currently offline Mujibur Rahman
Messages: 3
Registered: April 2012
Location: Bangalore
Junior Member
The org.h2_1.1.117.v201105142352.jar is included in the CLASSPATH. Is there any other libraries required to run the tests?
Re: Problem Running jubula tests with ant. No suitable driver found error [message #875352 is a reply to message #875329] Tue, 22 May 2012 15:18 Go to previous message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1152
Registered: July 2009
Senior Member
Hi,

This sounds like a problem other people have had. Have a look at these forum threads to see if they help at all:

http://www.eclipse.org/forums/index.php/t/263140/

http://www.eclipse.org/forums/index.php/t/262213/

HTH,
Alex
Previous Topic:ANT integration database problem
Next Topic:How to export single test cases between different databases
Goto Forum:
  


Current Time: Thu Sep 18 21:57:05 GMT 2014

Powered by FUDForum. Page generated in 0.01698 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software