Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EEF] [0..1] Composition Link Issue
[EEF] [0..1] Composition Link Issue [message #874778] Mon, 21 May 2012 14:26 Go to next message
Laurent Mattina is currently offline Laurent MattinaFriend
Messages: 5
Registered: April 2012
Junior Member
Hi,

I am using EEF to enhance the instantiation of a meta-model I built. The point is that when "generate EEF architecture", no composition link with cardinality [0..1] or [1..1] is taken into account. At the opposite, everything works perfectly fine with cardinality [0..*] composition links.

I tried to add the corresponding views on my own but it seems that the widget is "disconnected" (when I click on the "Add" button, nothing happens).

I cannot figure out the difference between [0..1] composition links and [0..*] ones. Has anyone ever faced this problem?

Thanks in advance,

Cheers,
Laurent
Re: [EEF] [0..1] Composition Link Issue [message #895892 is a reply to message #874778] Mon, 16 July 2012 12:53 Go to previous message
yashine Missing name is currently offline yashine Missing nameFriend
Messages: 12
Registered: June 2011
Junior Member
Laurent Mattina wrote on Mon, 21 May 2012 10:26
Hi,

I am using EEF to enhance the instantiation of a meta-model I built. The point is that when "generate EEF architecture", no composition link with cardinality [0..1] or [1..1] is taken into account. At the opposite, everything works perfectly fine with cardinality [0..*] composition links.

I tried to add the corresponding views on my own but it seems that the widget is "disconnected" (when I click on the "Add" button, nothing happens).

I cannot figure out the difference between [0..1] composition links and [0..*] ones. Has anyone ever faced this problem?

Thanks in advance,

Cheers,
Laurent


Hi,
I have the same problem and I am looking for the same thing. If you have found a solution please share it.

Cheers
Yashine
Previous Topic:[ECP] EMF Test Model Generator
Next Topic:Need a user-friendly editor for creating instances
Goto Forum:
  


Current Time: Wed Nov 26 04:35:14 GMT 2014

Powered by FUDForum. Page generated in 0.01714 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software