Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] Unstable behavior when using a query from an imported module
[Acceleo] Unstable behavior when using a query from an imported module [message #874034] Sat, 19 May 2012 20:10 Go to next message
Tomas Balderas is currently offline Tomas BalderasFriend
Messages: 46
Registered: July 2010
Member
Hello, I hope you can help me.

I have two modules in the same package of my project. The module A contains the following query:

[query public getOutputs(anAction: Action): Sequence(OutputPin) =
	anAction.output
	->select(op: OutputPin | op.isBBOutput())
	->asSequence()
/]


Then, I import module A in module B and use getOutputs in the following query in B:

[query public getOutputsMultiplicities(anOperation: OpaqueAction): Sequence(Integer) =
	anOperation.getOutputs()
	->collect(op: OutputPin | op.getMultiplicity())
	->asSequence()
/]


The behavior is unstable when building the project because Acceleo indicates the following error in getOutputsMultiplicities():

Iterator variable must have same type as source element type (anOperation.getOutputs()->collect(op : OutputPin | op.getMultiplicity())) Iterator variable must have same type as source element type (anOperation.getOutputs()->collect(op : OutputPin | op.getMultiplicity()))

When I clean and build the project the error disappears, but reappears whenever I do any modification in the file containing module B.

¿Any idea what is going on?

Thanks.


/TB
Re: [Acceleo] Unstable behavior when using a query from an imported module [message #874050 is a reply to message #874034] Sat, 19 May 2012 21:01 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4154
Registered: July 2009
Senior Member
Hi

This sounds like problems I had. Acceleo 3.3M7 fixed them.

Regards

Ed Willink

On 19/05/2012 21:10, Tomas Balderas wrote:
> Hello, I hope you can help me.
>
> I have two modules in the same package of my project. The module A
> contains the following query:
>
>
> [query public getOutputs(anAction: Action): Sequence(OutputPin) =
> anAction.output
> ->select(op: OutputPin | op.isBBOutput())
> ->asSequence()
> /]
>
>
> Then, I import module A in module B and use getOutputs in the
> following query in B:
>
>
> [query public getOutputsMultiplicities(anOperation: OpaqueAction):
> Sequence(Integer) =
> anOperation.getOutputs()
> ->collect(op: OutputPin | op.getMultiplicity())
> ->asSequence()
> /]
>
>
> The behavior is unstable when building the project because Acceleo
> indicates the following error in getOutputsMultiplicities():
>
> Iterator variable must have same type as source element type
> (anOperation.getOutputs()->collect(op : OutputPin |
> op.getMultiplicity())) Iterator variable must have same type as source
> element type (anOperation.getOutputs()->collect(op : OutputPin |
> op.getMultiplicity()))
>
> When I clean and build the project the error disappears, but reappears
> whenever I do any modification in the file containing module B.
>
> ¿Any idea what is going on?
>
> Thanks.
Re: [Acceleo] Unstable behavior when using a query from an imported module [message #874076 is a reply to message #874050] Sat, 19 May 2012 22:56 Go to previous messageGo to next message
Tomas Balderas is currently offline Tomas BalderasFriend
Messages: 46
Registered: July 2010
Member
Hi Ed.

Thanks for answering. According to the information I gathered, I have Acceleo SDK 3.1.3 in my Eclipse Modeling Tools Version: Indigo Service Release 2. A search for updates indicates that no updates are available. How can I install Acceleo 3.3M7?

Thanks.


/TB
Re: [Acceleo] Unstable behavior when using a query from an imported module [message #874128 is a reply to message #874050] Sun, 20 May 2012 02:42 Go to previous messageGo to next message
Tomas Balderas is currently offline Tomas BalderasFriend
Messages: 46
Registered: July 2010
Member
I installed Acceleo 3.3.0 M7 from the following repository:

http://download.eclipse.org/releases/juno

The problem seems to be no more. However, the perspective list tab in my workspace got a bit messy; no big deal. I installed Eclipse Juno M7 and all of my modeling infrastructure (Papyrus, Acceleo, OCL Editors and ATL), but when I opened my models in Papyrus, their layout changed, the icons for the applied stereotypes went small, and some elements were MISSING (although not in the .uml file in XMI).

I hope the Juno team and the Papyrus team fix issues by the official release day of Juno.

Thanks.


/TB
Re: [Acceleo] Unstable behavior when using a query from an imported module [message #874193 is a reply to message #874128] Sun, 20 May 2012 05:33 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4154
Registered: July 2009
Senior Member
Hi

The milestones enable enthusiasts to help in the debugging.

Please report Papyrus issues to the Papyrus team. I know that they've
been doing some significant restructuring so there may be things that
they've missed.

Regards

Ed Willink




On 20/05/2012 03:42, Tomas Balderas wrote:
> I installed Acceleo 3.3.0 M7 from the following repository:
>
> http://download.eclipse.org/releases/juno
>
> The problem seems to be no more. However, the perspective list tab in
> my workspace got a bit messy; no big deal. I installed Eclipse Juno M7
> and all of my modeling infrastructure (Papyrus, Acceleo, OCL Editors
> and ATL), but when I opened my models in Papyrus, their layout
> changed, the icons for the applied stereotypes went small, and some
> elements were MISSING (although not in the .uml file in XMI).
>
> I hope the Juno team and the Papyrus team fix issues by the official
> release day of Juno.
>
> Thanks.
Previous Topic:[XPAND] Traverse all elements of a class
Next Topic:[Acceleo] Transversal tree generation
Goto Forum:
  


Current Time: Thu Nov 27 11:09:05 GMT 2014

Powered by FUDForum. Page generated in 0.01753 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software