Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » UML2/EMF standalone
UML2/EMF standalone [message #873950] Sat, 19 May 2012 15:09 Go to next message
Eclipse UserFriend
Hi,

i'm trying to identify minimum set of UML2/EMF jars for my project.
The only functionality i need is beeing able to load uml models from xmi
files and then access those model elements.

Currently, i've included following jars (they are from old eclipse
version, but i'll update to equivalent jars from juno):

org.eclipse.emf.ecore_2.5.0.v200906151043.jar
org.eclipse.emf.ecore.xmi_2.5.0.v200906151043.jar
org.eclipse.emf.common_2.5.0.v200906151043.jar
org.eclipse.emf.exporter_2.5.0.v200906151043.jar
org.eclipse.emf.importer_2.5.0.v200906151043.jar
org.eclipse.emf_2.5.0.v200906151043.jar
org.eclipse.uml2.common_1.5.0.v200905041045.jar
org.eclipse.uml2.uml.ecore.exporter_2.3.0.v200905041045.jar
org.eclipse.uml2.uml.ecore.importer_2.3.0.v200905041045.jar
org.eclipse.uml2.uml.resources_3.0.0.v200906011111.jar
org.eclipse.uml2.uml_3.0.1.v200908281330.jar
org.eclipse.uml2_3.0.0.v200905041045.jar
org.eclipse.emf.converter_2.5.0.v200906151043.jar
org.eclipse.equinox.common_3.5.1.R35x_v20090807-1100.jar
org.eclipse.emf.codegen.ecore_2.5.0.v200906151043.jar
org.eclipse.emf.mapping.ecore2xml_2.5.0.v200906151043.jar
org.eclipse.emf.ecore.edit_2.5.0.v200906151043.jar
org.eclipse.emf.edit_2.5.0.v200906151043.jar
org.eclipse.uml2.common.edit_1.5.0.v200905041045.jar
org.eclipse.uml2.uml.edit_3.0.0.v200905041045.jar
org.eclipse.emf.ecore.change_2.5.0.v200906151043.jar

Trying to remove any of those jars from classpath results in different
exceptions. But i think, i just do that in wrong sequence, and i really
don't need some of jars. For example, codegen.ecore_2.5.0,
equinox-commmon or mapping.ecore_2.5.0. Any suggestions to filter out
unnecessary jars would be very helpful.

Thanks in advance.
Re: UML2/EMF standalone [message #873966 is a reply to message #873950] Sat, 19 May 2012 16:08 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4150
Registered: July 2009
Senior Member
Hi

importer/exporter/change can probably go.

mapping is needed for CMOF.

Use a plugin so that you have a manifest and then show the plugin
dependency hierarchy, and the remove unused dependencies tool.

Regards

Ed Willink

On 19/05/2012 16:09, Emil Huseynli wrote:
> Hi,
>
> i'm trying to identify minimum set of UML2/EMF jars for my project.
> The only functionality i need is beeing able to load uml models from
> xmi files and then access those model elements.
>
> Currently, i've included following jars (they are from old eclipse
> version, but i'll update to equivalent jars from juno):
>
> org.eclipse.emf.ecore_2.5.0.v200906151043.jar
> org.eclipse.emf.ecore.xmi_2.5.0.v200906151043.jar
> org.eclipse.emf.common_2.5.0.v200906151043.jar
> org.eclipse.emf.exporter_2.5.0.v200906151043.jar
> org.eclipse.emf.importer_2.5.0.v200906151043.jar
> org.eclipse.emf_2.5.0.v200906151043.jar
> org.eclipse.uml2.common_1.5.0.v200905041045.jar
> org.eclipse.uml2.uml.ecore.exporter_2.3.0.v200905041045.jar
> org.eclipse.uml2.uml.ecore.importer_2.3.0.v200905041045.jar
> org.eclipse.uml2.uml.resources_3.0.0.v200906011111.jar
> org.eclipse.uml2.uml_3.0.1.v200908281330.jar
> org.eclipse.uml2_3.0.0.v200905041045.jar
> org.eclipse.emf.converter_2.5.0.v200906151043.jar
> org.eclipse.equinox.common_3.5.1.R35x_v20090807-1100.jar
> org.eclipse.emf.codegen.ecore_2.5.0.v200906151043.jar
> org.eclipse.emf.mapping.ecore2xml_2.5.0.v200906151043.jar
> org.eclipse.emf.ecore.edit_2.5.0.v200906151043.jar
> org.eclipse.emf.edit_2.5.0.v200906151043.jar
> org.eclipse.uml2.common.edit_1.5.0.v200905041045.jar
> org.eclipse.uml2.uml.edit_3.0.0.v200905041045.jar
> org.eclipse.emf.ecore.change_2.5.0.v200906151043.jar
>
> Trying to remove any of those jars from classpath results in different
> exceptions. But i think, i just do that in wrong sequence, and i
> really don't need some of jars. For example, codegen.ecore_2.5.0,
> equinox-commmon or mapping.ecore_2.5.0. Any suggestions to filter out
> unnecessary jars would be very helpful.
>
> Thanks in advance.
Re: UML2/EMF standalone [message #873977 is a reply to message #873966] Sat, 19 May 2012 16:54 Go to previous messageGo to next message
Eclipse UserFriend
just removed emf_2.5.0 and everything seems still to work, very strange...

what about equinox.common?

> importer/exporter/change can probably go.
>
> mapping is needed for CMOF.

not a trivial task for me at the moment
> Use a plugin so that you have a manifest and then show the plugin
> dependency hierarchy, and the remove unused dependencies tool.
Re: UML2/EMF standalone [message #873985 is a reply to message #873950] Sat, 19 May 2012 17:24 Go to previous messageGo to next message
Eclipse UserFriend
Reduced jar-set to

org.eclipse.emf.ecore_2.5.0.v200906151043.jar
org.eclipse.emf.ecore.xmi_2.5.0.v200906151043.jar
org.eclipse.emf.common_2.5.0.v200906151043.jar
org.eclipse.uml2.common_1.5.0.v200905041045.jar
org.eclipse.uml2.uml.resources_3.0.0.v200906011111.jar
org.eclipse.uml2.uml_3.0.1.v200908281330.jar
org.eclipse.uml2_3.0.0.v200905041045.jar
org.eclipse.emf.mapping.ecore2xml_2.5.0.v200906151043.jar

Existing code works so far.

Is it possible that with removing all those jars i've excluded some
functionality related to loading uml models and traversing them?

On 19.05.2012 17:09, Emil Huseynli wrote:
> Hi,
>
> i'm trying to identify minimum set of UML2/EMF jars for my project.
> The only functionality i need is beeing able to load uml models from xmi
> files and then access those model elements.
>
> Currently, i've included following jars (they are from old eclipse
> version, but i'll update to equivalent jars from juno):
>
> org.eclipse.emf.ecore_2.5.0.v200906151043.jar
> org.eclipse.emf.ecore.xmi_2.5.0.v200906151043.jar
> org.eclipse.emf.common_2.5.0.v200906151043.jar
> org.eclipse.emf.exporter_2.5.0.v200906151043.jar
> org.eclipse.emf.importer_2.5.0.v200906151043.jar
> org.eclipse.emf_2.5.0.v200906151043.jar
> org.eclipse.uml2.common_1.5.0.v200905041045.jar
> org.eclipse.uml2.uml.ecore.exporter_2.3.0.v200905041045.jar
> org.eclipse.uml2.uml.ecore.importer_2.3.0.v200905041045.jar
> org.eclipse.uml2.uml.resources_3.0.0.v200906011111.jar
> org.eclipse.uml2.uml_3.0.1.v200908281330.jar
> org.eclipse.uml2_3.0.0.v200905041045.jar
> org.eclipse.emf.converter_2.5.0.v200906151043.jar
> org.eclipse.equinox.common_3.5.1.R35x_v20090807-1100.jar
> org.eclipse.emf.codegen.ecore_2.5.0.v200906151043.jar
> org.eclipse.emf.mapping.ecore2xml_2.5.0.v200906151043.jar
> org.eclipse.emf.ecore.edit_2.5.0.v200906151043.jar
> org.eclipse.emf.edit_2.5.0.v200906151043.jar
> org.eclipse.uml2.common.edit_1.5.0.v200905041045.jar
> org.eclipse.uml2.uml.edit_3.0.0.v200905041045.jar
> org.eclipse.emf.ecore.change_2.5.0.v200906151043.jar
>
> Trying to remove any of those jars from classpath results in different
> exceptions. But i think, i just do that in wrong sequence, and i really
> don't need some of jars. For example, codegen.ecore_2.5.0,
> equinox-commmon or mapping.ecore_2.5.0. Any suggestions to filter out
> unnecessary jars would be very helpful.
>
> Thanks in advance.
Re: UML2/EMF standalone [message #873986 is a reply to message #873950] Sat, 19 May 2012 17:29 Go to previous messageGo to next message
Rafael Chaves is currently offline Rafael ChavesFriend
Messages: 23
Registered: April 2012
Junior Member
In the TextUML Toolkit and AlphaSimple projects, which create and read UML models in batch mode (no "edit" support), these are all EMF and UML plugins I needed:

From EMF, all I use is:

org.eclipse.emf.common_2.7.0.v20120127-1122.jar
org.eclipse.emf.ecore_2.7.0.v20120127-1122.jar
org.eclipse.emf.ecore.xmi_2.7.0.v20120127-1122.jar
org.eclipse.emf.mapping.ecore2xml_2.7.0.v20120130-0943.jar

From UML, all I use is:

org.eclipse.uml2.common_1.6.0.v201105021727.jar
org.eclipse.uml2.uml_3.2.100.v201108110105.jar
org.eclipse.uml2.uml.resources_3.1.100.v201008191510.jar


These are OSGi-based applications though - however, I don't see how more would be necessary just to support a standalone application.
Re: UML2/EMF standalone [message #873992 is a reply to message #873986] Sat, 19 May 2012 17:50 Go to previous messageGo to next message
Eclipse UserFriend
thanks, i've removed this jar too

org.eclipse.uml2_3.0.0.v200905041045.jar

and seems nothing get broken so far

On 19.05.2012 19:29, Rafael Chaves wrote:
> In the TextUML Toolkit and AlphaSimple projects, which create and read
> UML models in batch mode (no "edit" support), these are all EMF and UML
> plugins I needed:
>
> From EMF, all I use is:
>
> org.eclipse.emf.common_2.7.0.v20120127-1122.jar
> org.eclipse.emf.ecore_2.7.0.v20120127-1122.jar
> org.eclipse.emf.ecore.xmi_2.7.0.v20120127-1122.jar
> org.eclipse.emf.mapping.ecore2xml_2.7.0.v20120130-0943.jar
>
> From UML, all I use is:
>
> org.eclipse.uml2.common_1.6.0.v201105021727.jar
> org.eclipse.uml2.uml_3.2.100.v201108110105.jar
> org.eclipse.uml2.uml.resources_3.1.100.v201008191510.jar
>
>
> These are OSGi-based applications though - however, I don't see how more
> would be necessary just to support a standalone application.
Re: UML2/EMF standalone [message #875269 is a reply to message #873992] Tue, 22 May 2012 12:47 Go to previous messageGo to next message
Christian W. Damus is currently offline Christian W. DamusFriend
Messages: 830
Registered: July 2009
Senior Member
Hi, Emil,

That JAR is just a branding plug-in. It contains the source models of
the UML from OMG and some custom codegen templates used by the UML2
project, but no code.

Cheers,

Christian

On 2012-05-19 17:50:09 +0000, Emil Huseynli said:

> thanks, i've removed this jar too
>
> org.eclipse.uml2_3.0.0.v200905041045.jar
>
> and seems nothing get broken so far
>
> On 19.05.2012 19:29, Rafael Chaves wrote:
>> In the TextUML Toolkit and AlphaSimple projects, which create and read
>> UML models in batch mode (no "edit" support), these are all EMF and UML
>> plugins I needed:
>>
>> From EMF, all I use is:
>>
>> org.eclipse.emf.common_2.7.0.v20120127-1122.jar
>> org.eclipse.emf.ecore_2.7.0.v20120127-1122.jar
>> org.eclipse.emf.ecore.xmi_2.7.0.v20120127-1122.jar
>> org.eclipse.emf.mapping.ecore2xml_2.7.0.v20120130-0943.jar
>>
>> From UML, all I use is:
>>
>> org.eclipse.uml2.common_1.6.0.v201105021727.jar
>> org.eclipse.uml2.uml_3.2.100.v201108110105.jar
>> org.eclipse.uml2.uml.resources_3.1.100.v201008191510.jar
>>
>>
>> These are OSGi-based applications though - however, I don't see how more
>> would be necessary just to support a standalone application.
Re: UML2/EMF standalone [message #875271 is a reply to message #875269] Tue, 22 May 2012 12:54 Go to previous message
Christian W. Damus is currently offline Christian W. DamusFriend
Messages: 830
Registered: July 2009
Senior Member
Oh, and the source models and templates are only included in the source
build, not the binary distribution, anyways …

cW


On 2012-05-22 12:47:59 +0000, Christian W. Damus said:

> Hi, Emil,
>
> That JAR is just a branding plug-in. It contains the source models of
> the UML from OMG and some custom codegen templates used by the UML2
> project, but no code.
>
> Cheers,
>
> Christian
>
> On 2012-05-19 17:50:09 +0000, Emil Huseynli said:
>
>> thanks, i've removed this jar too
>>
>> org.eclipse.uml2_3.0.0.v200905041045.jar
>>
>> and seems nothing get broken so far
>>
>> On 19.05.2012 19:29, Rafael Chaves wrote:
>>> In the TextUML Toolkit and AlphaSimple projects, which create and read
>>> UML models in batch mode (no "edit" support), these are all EMF and UML
>>> plugins I needed:
>>>
>>> From EMF, all I use is:
>>>
>>> org.eclipse.emf.common_2.7.0.v20120127-1122.jar
>>> org.eclipse.emf.ecore_2.7.0.v20120127-1122.jar
>>> org.eclipse.emf.ecore.xmi_2.7.0.v20120127-1122.jar
>>> org.eclipse.emf.mapping.ecore2xml_2.7.0.v20120130-0943.jar
>>>
>>> From UML, all I use is:
>>>
>>> org.eclipse.uml2.common_1.6.0.v201105021727.jar
>>> org.eclipse.uml2.uml_3.2.100.v201108110105.jar
>>> org.eclipse.uml2.uml.resources_3.1.100.v201008191510.jar
>>>
>>>
>>> These are OSGi-based applications though - however, I don't see how more
>>> would be necessary just to support a standalone application.
Previous Topic:UML2 3.x Resources with 4.x
Next Topic:Store model in database
Goto Forum:
  


Current Time: Sun Nov 23 19:09:27 GMT 2014

Powered by FUDForum. Page generated in 0.01776 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software