Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Indexer ... it seems I cant get how it is supposed to work
Indexer ... it seems I cant get how it is supposed to work [message #873575] Fri, 18 May 2012 11:09 Go to next message
ZePequeno . is currently offline ZePequeno .
Messages: 7
Registered: September 2011
Junior Member
Hello everyone,

I have been using Eclipse with some minor setbacks, for the last 9 months for developing a quite large project made up of several components; each component are in C++, and they all are makefile projects.

Everything has been going on smoothly until today, when I needed to create a new project for a new c++ static library. It seems I cant manage to have indexer discover the paths of the included files by himself. Up until today in the project explorer, under the "Includes" item, I was able to see all the referenced paths of other components with a purple icon; starting today, when I rebuild the index those "purple" folder icons dont show up anymore, and nearly every line of code is underlined in red and the C++ perspective appears as filled with any kind of errors. Obviously Auto-completion and symbol finding doesnt work anymore Sad

Of course if I build the project there are no errors, and the build process completes successfully.

What is even more annoying is that all my colleagues still see those purple folders, and the indexer works perfectly for them.

Anyone having some suggestions?


this is the version I am using for Linux:
Version: Indigo Release
Build id: 20110615-0604

if you think I should provide any further info I will be very happy to provide it... I am just so sad today Sad

regards

Filippo :'(
Re: Indexer ... it seems I cant get how it is supposed to work [message #875161 is a reply to message #873575] Tue, 22 May 2012 04:53 Go to previous message
ZePequeno . is currently offline ZePequeno .
Messages: 7
Registered: September 2011
Junior Member
ZePequeno . wrote on Fri, 18 May 2012 11:09

...
they all are makefile projects.
...


Well.. it appears that I have found the root cause of the indexer "failing".

I stumpled upon this page: (sorry for the missing direct link but it appears that I cant post links until I post 25 messages)
www.phy.bme.hu/~cluster/docs/cc/main_cls/mergedProjects/bldaps_cls/cppug_ccl/bldaps_overview_scanner_collector.htm

where the relevant statement is:
Quote:
Enabling this support causes the CDT to 'snoop' and parse the build process output to extract the otherwise invisible build path information.


The point is that recently I have changed the make process output, so that the classic g++ command echo is not printed anymore. Putting back g++ command echo brings indexer back to life.

Does anyone know how does CDT "snoops and parses" the build process output?

hope it helps someone else too.

Best Regards

[Updated on: Tue, 22 May 2012 04:53]

Report message to a moderator

Previous Topic:Selection of Language Extension
Next Topic:Multiple main
Goto Forum:
  


Current Time: Fri Apr 18 14:13:29 EDT 2014

Powered by FUDForum. Page generated in 0.02546 seconds