Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » XPand non containment references(No items in non containment references)
XPand non containment references [message #871808] Mon, 14 May 2012 23:03 Go to next message
Daniel Winkels is currently offline Daniel WinkelsFriend
Messages: 19
Registered: October 2010
Junior Member
hello,

i am developing a xpand template to generate some code (surprise!). the model contains a dialog which has a containment reference "components" where Components are stored. in another part of the model i need to reference these components with a non-containment reference.

when i want to expand theses non-containment references, they are empty. i am testing with a dynamic ecore instance of my model. might this be a problem?

perhaps can someone give me a hint.

thank you for your time!

daniel
  • Attachment: thc.ecore
    (Size: 3.27KB, Downloaded 98 times)
Re: XPand non containment references [message #871907 is a reply to message #871808] Tue, 15 May 2012 05:58 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 6485
Registered: July 2009
Senior Member
Hi,

this should work straight forward.
can you share your workflow our however you execute your stuff too?

~Christian
Re: XPand non containment references [message #872129 is a reply to message #871907] Tue, 15 May 2012 14:07 Go to previous messageGo to next message
Daniel Winkels is currently offline Daniel WinkelsFriend
Messages: 19
Registered: October 2010
Junior Member
thats what i thought, too.

the model is not as goog as i wanted it to be t fit the problem, but it will work as a proof of concept.
Re: XPand non containment references [message #872167 is a reply to message #872129] Tue, 15 May 2012 15:24 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 6485
Registered: July 2009
Senior Member
Hi are you seriously testing with the model attached? You did not fill any of the crossrefs
Re: XPand non containment references [message #872171 is a reply to message #872167] Tue, 15 May 2012 15:35 Go to previous messageGo to next message
Daniel Winkels is currently offline Daniel WinkelsFriend
Messages: 19
Registered: October 2010
Junior Member
hey,

you're right. looks like i am making a mistake somewhere. i had them filled but when i checked in the xmi file again, they were lost. can this behaviour be related to the dynamic instance?

thanks for this hint - i did not close the model-editor, so i did not see this behaviour.

daniel
Re: XPand non containment references [message #872175 is a reply to message #872171] Tue, 15 May 2012 15:40 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 6485
Registered: July 2009
Senior Member
Hi if you set containment false at all ref places no.
Previous Topic:acceleo 3 - passing collection type as a parameter to a Java service problem
Next Topic:[Galileo, XPAND] Select just one Object with the same name
Goto Forum:
  


Current Time: Mon Nov 24 04:22:32 GMT 2014

Powered by FUDForum. Page generated in 0.02485 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software