Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » error no preview data with web service data source(data source birt problem)
error no preview data with web service data source [message #871253] Fri, 11 May 2012 12:18 Go to next message
jose susa is currently offline jose susa
Messages: 3
Registered: May 2012
Junior Member
I have been learning birt to make some reports with web service as data source; however I have had some issues with some web services. I can't see any data at the preview screen when I'm trying to create the data set.

The web service is public: http:--footballpool.dataaccess.eu-data-info.wso?WSDL (change the "-" by "/" , sorry the forum didnt want me to put the link)

When I tried some operations like "cities" and "StadiumNames" but when I'm on the Column mapping at the dataset´s wizard I don't see any data.

I used soapUI to test the web service first and the specific operations I mentioned, they worked fine.

Can you suggest me what I should do to see the results. Do I have to configure something during the wizard. Can you try with this web service and those specific operations?

Thank you so much for your help.

Jose L.

[Updated on: Fri, 11 May 2012 12:19]

Report message to a moderator

Re: error no preview data with web service data source [message #871270 is a reply to message #871253] Fri, 11 May 2012 13:31 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

I can not seem to access this link.

Jason

On 5/11/2012 12:18 PM, jose susa wrote:
> I have been learning birt to make some reports with web service as data
> source; however I have had some issues with some web services. I can't
> see any data at the preview screen when I'm trying to create the data set.
>
> The web service is public:
> http:--footballpool.dataaccess.eu-data-info.wso?WSDL (change the "-" by
> / , sorry the forum didnt want me to put the link)
>
> When I tried some operations like "cities" and "StadiumNames" but when
> I'm on the Column mapping at the dataset´s wizard I don't see any data.
>
> I used soapUI to test the web service first and the specific operations
> I mentioned, they worked fine.
>
> Can you suggest me what I should do to see the results. Do I have to
> configure something during the wizard. Can you try with this web service
> and those specific operations?
>
> Thank you so much for your help.
>
> Jose L.
Re: error no preview data with web service data source [message #871307 is a reply to message #871270] Fri, 11 May 2012 16:38 Go to previous messageGo to next message
jose susa is currently offline jose susa
Messages: 3
Registered: May 2012
Junior Member
I had to changed the characters "/" by 4 characters"-" on the link bc Im new at the forum and i cant post links (annoying Sad ).

Just switch the 4 characters "-" that you see on my link by 4 characters "/" the link works.

there are 2 between http:: and footballpool
there is 1 between .eu and data
there is 1 between data and info
Re: error no preview data with web service data source [message #871588 is a reply to message #871270] Mon, 14 May 2012 09:25 Go to previous messageGo to next message
Colin  is currently offline Colin
Messages: 14
Registered: September 2010
Junior Member
The link works if you replace the minuses with slashes. Stop at the
question mark (leave off the WSDL) to see the selectors.
--
Colin

Jason Weathersby <jasonweathersby@xxxxxxxx> wrote:
> I can not seem to access this link.
>
> Jason
>
> On 5/11/2012 12:18 PM, jose susa wrote:
>> I have been learning birt to make some reports with web service as data
>> source; however I have had some issues with some web services. I can't
>> see any data at the preview screen when I'm trying to create the data set.
>>
>> The web service is public:
>> http:--footballpool.dataaccess.eu-data-info.wso?WSDL (change the "-" by
>> / , sorry the forum didnt want me to put the link)
>>
>> When I tried some operations like "cities" and "StadiumNames" but when
>> I'm on the Column mapping at the dataset´s wizard I don't see any data.
>>
>> I used soapUI to test the web service first and the specific operations
>> I mentioned, they worked fine.
>>
>> Can you suggest me what I should do to see the results. Do I have to
>> configure something during the wizard. Can you try with this web service
>> and those specific operations?
>>
>> Thank you so much for your help.
>>
>> Jose
Re: error no preview data with web service data source [message #871602 is a reply to message #871588] Mon, 14 May 2012 10:04 Go to previous messageGo to next message
jose susa is currently offline jose susa
Messages: 3
Registered: May 2012
Junior Member
Colin,

Could you use the WSDL as datasource and the operation "cities" and its fields as dataset? Could you see data at the preview view?
Re: error no preview data with web service data source [message #871742 is a reply to message #871602] Mon, 14 May 2012 15:23 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you open a bugzilla entry for this. When I use the web service and
create a data set and then use the dataset in a table I get:

Caused by: org.eclipse.datatools.connectivity.oda.OdaException: no
protocol:
at
org.eclipse.datatools.enablement.oda.ws.util.RawMessageSender.getSOAPResponse(RawMessageSender.java:107)
at
org.eclipse.datatools.enablement.oda.ws.impl.Query.getInputStream(Query.java:184)
at
org.eclipse.datatools.enablement.oda.ws.impl.Query.initXMLQuery(Query.java:136)
at
org.eclipse.datatools.enablement.oda.ws.impl.Query.executeQuery(Query.java:128)
at
org.eclipse.datatools.connectivity.oda.consumer.helper.OdaQuery.doExecuteQuery(OdaQuery.java:469)
at
org.eclipse.datatools.connectivity.oda.consumer.helper.OdaQuery.executeQuery(OdaQuery.java:433)
at
org.eclipse.birt.data.engine.odaconsumer.PreparedStatement.execute(PreparedStatement.java:575)


Jason


On 5/14/2012 10:04 AM, jose susa wrote:
> Colin,
> Could you use the WSDL as datasource and the operation "cities" and its
> fields as dataset? Could you see data at the preview view?
Previous Topic:Unable to run Chart Report with CrossTabs using BIRT 2.6.2
Next Topic:Drill down option
Goto Forum:
  


Current Time: Sat Aug 30 12:29:59 EDT 2014

Powered by FUDForum. Page generated in 0.33443 seconds