Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Copy&paste of library items in the designer does not preserve the library dependency(The copied item does not preserve the reference to orginal library)
Copy&paste of library items in the designer does not preserve the library dependency [message #870454] Tue, 08 May 2012 10:26 Go to next message
ing omini is currently offline ing omini
Messages: 25
Registered: March 2012
Junior Member
Hi,
I have the following issue.

My rptdesign is using an external rptlibrary in which I define some basic formatting for charts.

When I drag and drop a library item into the design and make some customization, everything is ok: the link to the original library item is defined.
That is, in the xml source I have the attribute: extends="mylib.myitem".
So, changes to the library item will correctly reflect on the item instance inside the design.

Let's call item_X the item instance inside the report.

When I try to copy and paste item_X to have item_Y, I find out that item_Y is NOT linked to the library.

Of course as a woraround I can go inside the XML source and add the missing attribute: extends="mylib.myitem"
But I would exepect BIRT to preserve this information during the copy/paste operation.

Is it a bug related only to my version (Eclipse BIRT Designer Version 2.3.2.r232_20090202)?

Is there another way of "smart" copying items which preserves this library dependency, without changing the xml manually?

Thanks!
Re: Copy&paste of library items in the designer does not preserve the library dependency [message #870585 is a reply to message #870454] Tue, 08 May 2012 20:43 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

What types of customizations do you make. I tried the copy and paste
with a grid in 3.7.2 and it worked.

Jason

On 5/8/2012 6:27 AM, ing omini wrote:
> Hi,
> I have the following issue.
>
> My rptdesign is using an external rptlibrary in which I define some
> basic formatting for charts.
>
> When I drag and drop a library item into the design and make some
> customization, everything is ok: the link to the original library item
> is defined.
> That is, in the xml source I have the attribute: extends="mylib.myitem".
> So, changes to the library item will correctly reflect on the item
> instance inside the design.
>
> Let's call item_X the item instance inside the report.
>
> When I try to copy and paste item_X to have item_Y, I find out that
> item_Y is NOT linked to the library.
>
> Of course as a woraround I can go inside the XML source and add the
> missing attribute: extends="mylib.myitem"
> But I would exepect BIRT to preserve this information during the
> copy/paste operation.
>
> Is it a bug related only to my version (Eclipse BIRT Designer Version
> 2.3.2.r232_20090202)?
> Is there another way of "smart" copying items which preserves this
> library dependency, without changing the xml manually?
>
> Thanks!
Re: Copy&paste of library items in the designer does not preserve the library dependency [message #870593 is a reply to message #870585] Tue, 08 May 2012 21:10 Go to previous messageGo to next message
ing omini is currently offline ing omini
Messages: 25
Registered: March 2012
Junior Member
The library items are chart with basic formatting (like axis font, chart type, labels, etc...), with NO dataset associated
The report design instances customize the chart item, by binding a dataset to it, choosing the columns to be visualized and changing the titles.



Re: Copy&paste of library items in the designer does not preserve the library dependency [message #870597 is a reply to message #870593] Tue, 08 May 2012 21:31 Go to previous message
ing omini is currently offline ing omini
Messages: 25
Registered: March 2012
Junior Member
I tried also to reproduce the issue in a new report.
I can confirm that not always the copy/paste is losing the library item reference...
So I'll try to understand which kind of customization is determining the issue.

Thanks again
Previous Topic:Sorting in Cross tab is not working
Next Topic:Problem in previewing report in Birt designer 3.7 in Eclipse Indigo
Goto Forum:
  


Current Time: Mon Sep 22 12:32:05 GMT 2014

Powered by FUDForum. Page generated in 0.01573 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software