Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Osgi bug in log4j prevents osgi unaware web-app from startup
Osgi bug in log4j prevents osgi unaware web-app from startup [message #870214] Mon, 07 May 2012 05:57 Go to next message
David Koch is currently offline David Koch
Messages: 10
Registered: March 2012
Junior Member
Hello,

I've tried to deploy my Osgi unaware web application into the virgo-tomcat-server.
Unfortunately an Osgi error in log4j prevents the application from starting up.

The log4j manifest contains duplicate import package entries which is considered to be a bug.

But the log4j jar is just a private, embedded lib of my war file. Neither do I use it through Osgi nor is it supposed to be deployed into the osgi container. Its just a private lib of the webapp and should not be validated against osgi standard?

Thanks,
David

Re: Osgi bug in log4j prevents osgi unaware web-app from startup [message #873427 is a reply to message #870214] Fri, 18 May 2012 04:04 Go to previous message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
I agree Virgo should probably be more tolerant here. Please could you raise a bug and attach a trivial app to reproduce the problem?
Previous Topic:Can 'plan' be renamed to something more unique?
Next Topic:Access rules in bundle dependencies which can't be changed
Goto Forum:
  


Current Time: Wed Aug 20 06:48:46 EDT 2014

Powered by FUDForum. Page generated in 0.01489 seconds