Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remus Information Management » Dependency Issue with IDE
Dependency Issue with IDE [message #870098] Sun, 06 May 2012 12:59 Go to next message
Scott L Holmes is currently offline Scott L Holmes
Messages: 3
Registered: May 2012
Junior Member
I'm using Eclipse Helios and this update site:
Remus Information Management - remus-software.org/updatesites/remus

I'm getting the following dependency error when trying to install the Enablement component:

Cannot complete the install because of a conflicting dependency.
Software being installed: Enablement 0.3.0.201109010125 (org.remus.infomgntmnt.enablement.feature.group 0.3.0.201109010125)
Software currently installed: Eclipse IDE for Javascript Developers 1.3.2.20110301-1807 (epp.package.javascript 1.3.2.20110301-1807)
Only one of the following can be installed at once:
Eclipse IDE UI 3.6.1.M20100825-0800 (org.eclipse.ui.ide 3.6.1.M20100825-0800)
Eclipse IDE UI 3.6.0.I20100601-0800 (org.eclipse.ui.ide 3.6.0.I20100601-0800)
Eclipse IDE UI 3.6.2.M20101201-0800 (org.eclipse.ui.ide 3.6.2.M20101201-0800)
Cannot satisfy dependency:
From: Eclipse IDE for Javascript Developers 1.3.2.20110301-1807 (epp.package.javascript 1.3.2.20110301-1807)
To: org.eclipse.epp.package.javascript.feature.feature.group [1.3.2.20110301-1807]
Cannot satisfy dependency:
From: Javascript IDE Feature 1.3.2.20110301-1807 (org.eclipse.epp.package.javascript.feature.feature.group 1.3.2.20110301-1807)
To: org.eclipse.platform.feature.group [3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)
To: org.eclipse.ui.ide [3.6.2.M20101201-0800]
Cannot satisfy dependency:
From: Enablement 0.3.0.201109010125 (org.remus.infomgntmnt.enablement.feature.group 0.3.0.201109010125)
To: org.eclipse.ui.ide [3.6.1.M20100825-0800]

Re: Dependency Issue with IDE [message #870220 is a reply to message #870098] Mon, 07 May 2012 10:19 Go to previous messageGo to next message
Scott L Holmes is currently offline Scott L Holmes
Messages: 3
Registered: May 2012
Junior Member
I had reported elsewhere that I did not have a Remus button on the main toolbar of the Eclipse IDE. I recently created a new workspace and the Remus button appeared. I'm now able to view and work with the Desktop-Panel.
Re: Dependency Issue with IDE [message #870274 is a reply to message #870098] Mon, 07 May 2012 14:35 Go to previous messageGo to next message
Tom Seidel is currently offline Tom Seidel
Messages: 90
Registered: July 2009
Member
Scott,

The enablement feature is in the first place for the standalone application. If you install Remus into an IDE it's not neccessary to select this feature (probably we add here an "(Optional)".

In general it's recommended to install Remus via Eclipse Marketplace Client.

Cheers
Tom
Re: Dependency Issue with IDE [message #870391 is a reply to message #870274] Mon, 07 May 2012 23:09 Go to previous message
Scott L Holmes is currently offline Scott L Holmes
Messages: 3
Registered: May 2012
Junior Member
Thanks! I later found the tutorial on loading up the IDE.
When I install in the future on other computers, I'll use the Marketplace.
Previous Topic:Market Install? PDF viewing?
Next Topic:Timestamp on unit header
Goto Forum:
  


Current Time: Sun Oct 26 05:17:30 GMT 2014

Powered by FUDForum. Page generated in 0.33758 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software