Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Profiling under linux x86-64
Profiling under linux x86-64 [message #113853] Tue, 02 October 2007 16:11 Go to next message
Eclipse User
Originally posted by: kea031.gmail.com

Hi, I've tried to profile a java app with the recently released TPTP
4.4.0.3.
The IAC still doesn't work at all. As for the AC, when I start a profile,
I get the following error:

The JVMTI agent org.eclipse.tptp.jvmti is not available. Make sure that
the libraries for the agent are available and that it is configured
properly.

In the plugins directory, I've got that:

ls | grep jvmti
org.eclipse.tptp.platform.jvmti.client_4.4.0.v200707090100.j ar
org.eclipse.tptp.platform.jvmti.client_4.4.0.v200708071640.j ar
org.eclipse.tptp.platform.jvmti.client_4.4.1.v200709261752.j ar
org.eclipse.tptp.platform.jvmti.runtime_4.4.0.v200706290100
org.eclipse.tptp.platform.jvmti.runtime_4.4.0.v200708010927
org.eclipse.tptp.platform.jvmti.runtime_4.4.1.v200709261752
org.eclipse.tptp.platform.jvmti.source_4.3.0.v200707090100
org.eclipse.tptp.platform.jvmti.source_4.3.0.v200707090100-7 777-0r733G3I3A4H9_
org.eclipse.tptp.trace.jvmti.client_4.4.0.v200707090100.jar
org.eclipse.tptp.trace.jvmti.client_4.4.1.v200709261752.jar
org.eclipse.tptp.trace.jvmti.source_4.2.0.v200707090100
org.eclipse.tptp.trace.jvmti.source_4.2.0.v200707090100-33-- w3118181_1211

and my LD_LIBRARY_PATH contains the following directories :
$ECLIPSEHOME/plugins/org.eclipse.tptp.platform.ac.linux_em64 t_4.4.1.v200709261752/agent_controller/lib
$ECLIPSEHOME/lib
$ECLIPSEHOME/plugins/org.eclipse.tptp.platform.jvmti.runtime _4.4.1.v200709261752/agent_files/linux_em64t

The AC log is quite big (10000 lines). Should I post it?
Re: Profiling under linux x86-64 [message #113894 is a reply to message #113853] Tue, 02 October 2007 20:14 Go to previous messageGo to next message
Eclipse User
Originally posted by: wegener.cboenospam.com

Make sure that the libraries have the execute permission set for them.

"Rapha
Re: Profiling under linux x86-64 [message #113921 is a reply to message #113894] Wed, 03 October 2007 08:14 Go to previous message
Eclipse User
Originally posted by: kea031.gmail.com

Dave Wegener wrote:

> Make sure that the libraries have the execute permission set for them.

They have.
Previous Topic:api recorder problems
Next Topic:Unable to load transport layer
Goto Forum:
  


Current Time: Mon Sep 15 09:37:55 GMT 2014

Powered by FUDForum. Page generated in 0.03079 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software