Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Connect to Eclipse Bugzilla stall(Too little info in query, never returns)
Connect to Eclipse Bugzilla stall [message #869699] Thu, 03 May 2012 21:27 Go to next message
Eric Cloninger is currently offline Eric CloningerFriend
Messages: 1
Registered: July 2009
Junior Member
[Apologies if this is a double post. Forums kicked me out as I was posting the first time.]

Mylyn 3.6.5.v20120215-0100 in Eclipse 3.7.2 with EGit Mylyn 1.3.0.201202151440-r

I can create repositories to github.com and bugs.eclipse.org. Can validate settings on each. Created gists and issues queries to github. All successful.

Wanted to create a "My Issues" query on Eclipse Bugzilla. I filled out the query form using the wizard as shown. the only fields I filled out were the query title and my email address, along with the qualifier "is". (See Screenshot)

When I would go to synchronize the query, it would run without end. I don't have that many total bugs in the system (~71), so it shouldn't run forever. But it would just sit at 0% forever. It wasn't until I went back and selected the checkboxes and made further refinements on the form that I started getting results.

I know setting up development tools isn't the easiest thing in the world, but many of the players in the lifecycle aren't developers. I was operating on instinct, not poring over a manual. I know how to operate the web-based bugzilla, but I haven't spent any time with the Mylyn interface. I think if this situation is going to cause the server to spin indefinitely, the UX should have some front-end logic to guide me toward creating a correct query.

-E
Re: Connect to Eclipse Bugzilla stall [message #869805 is a reply to message #869699] Fri, 04 May 2012 11:11 Go to previous message
Steffen Pingel is currently offline Steffen PingelFriend
Messages: 706
Registered: July 2009
Senior Member
Hi,

thanks for your insightful input. This type of feedback is very helpful to
streamline workflows in the tooling and improve the UI experience.

The particular issue that you raised was addressed in the 3.7 release. The
query dialog now shows a message in the header when an email address is
entered but none of the checkboxes are selected. More details are on this
bug:

368295: all results returned when querying for user but not specifying
the fields to search
https://bugs.eclipse.org/bugs/show_bug.cgi?id=368295

Please feel free to open tasks in our Bugzilla at any time if you notice
shortcomings in the UI design.

Steffen


Eric Cloninger wrote:

> [Apologies if this is a double post. Forums kicked me out as I was posting
> [the first time.]
>
> Mylyn 3.6.5.v20120215-0100 in Eclipse 3.7.2 with EGit Mylyn
> 1.3.0.201202151440-r
>
> I can create repositories to github.com and bugs.eclipse.org. Can validate
> settings on each. Created gists and issues queries to github. All
> successful.
>
> Wanted to create a "My Issues" query on Eclipse Bugzilla. I filled out the
> query form using the wizard as shown. the only fields I filled out were
> the query title and my email address, along with the qualifier "is". (See
> Screenshot)
>
> When I would go to synchronize the query, it would run without end. I
> don't have that many total bugs in the system (~71), so it shouldn't run
> forever. But it would just sit at 0% forever. It wasn't until I went
> back and selected the checkboxes and made further refinements on the form
> that I started getting results.
>
> I know setting up development tools isn't the easiest thing in the world,
> but many of the players in the lifecycle aren't developers. I was
> operating on instinct, not poring over a manual. I know how to operate
> the web-based bugzilla, but I haven't spent any time with the Mylyn
> interface. I think if this situation is going to cause the server to spin
> indefinitely, the UX should have some front-end logic to guide me toward
> creating a correct query.
>
> -E
--
Steffen Pingel
Committer, http://eclipse.org/mylyn
Senior Developer, http://tasktop.com
Previous Topic:Bugzilla - no attachment
Next Topic:Mylyn 3.7 is now available
Goto Forum:
  


Current Time: Sun Dec 21 08:47:39 GMT 2014

Powered by FUDForum. Page generated in 0.03946 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software