Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Unable to load transport layer
Unable to load transport layer [message #113825] Tue, 02 October 2007 14:59 Go to next message
Eclipse User
Originally posted by: hichamm.orcsoftware.com

hello,
TPTP-4.4.1-200709101254 linux em64T

Starting the AController, in servicelog.log
there is

Unable to load transport layer: socketTL libsocketTL.so

<sourceComponentId component="AgentController"
componentIdType="TPTPComponent" executionEnvironment="ConnectionManager.c,
line 190" instanceId="2" location="k2.orcsoftware.com" locationType="IPV4"
processId="11763" subComponent="Connection Manager" threadId="11763"
componentType="Eclipse_TPTP"/>

1. there is some junk after the name of the .so file
ps: also for other libraries, which were successfully loaded.

2. should libsocketTL.so be part of TPTP-4.4.1-200709101254 zip file?
LD_LIBRARY_PATH is set to <...>/lib

3. parsing more the servicelog.log with:
grep msg= servicelog.log | awk -F'"' '{ print $6 '} |grep port
File server started listening on port 10005

However, SampleClient fails to connect to port 10006.
serviceconfig.xml shows:
<Connection name="Dev">
<TransportLayer loadlib="socketTL" type="TPTP_SOCKET">
<Configuration>
<Port>10006</Port>
<SecurityEnabled>false</SecurityEnabled>
</Configuration>
<CommandExtractor>tptpCmdExtr</CommandExtractor>

so i guess it is understandable SampleClient fails.
I need libsocketTL.so

any ideas?
Re: Unable to load transport layer [message #113947 is a reply to message #113825] Wed, 03 October 2007 11:21 Go to previous messageGo to next message
Eclipse User
Originally posted by: hichamm.orcsoftware.com

This is bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=203218
fixed sep13 ?
Re: Unable to load transport layer [message #114011 is a reply to message #113947] Wed, 03 October 2007 14:38 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor Alelekov
Messages: 139
Registered: July 2009
Senior Member
Hi Hicham,
The patch for the defect #203218, fixing the issue, hasn't been approved
yet.
Re: Unable to load transport layer [message #114020 is a reply to message #113947] Wed, 03 October 2007 14:42 Go to previous message
Igor Alelekov is currently offline Igor Alelekov
Messages: 139
Registered: July 2009
Senior Member
Hicham,
You can use TPTP 4.4.0.3, which should be free from this defect.
Regards,
Igor
Previous Topic:Profiling under linux x86-64
Next Topic:[agr] please explain the meaning of this exception
Goto Forum:
  


Current Time: Sat Oct 25 17:45:58 GMT 2014

Powered by FUDForum. Page generated in 0.01719 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software