Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Unable to run Chart Report with CrossTabs using BIRT 2.6.2(BIRT 2.6.2 - Runtime Exception - java.lang.ClassCastException: java.lang.NoClassDefFoundError received. No Stack Trace printed)
Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #869542] Thu, 03 May 2012 14:55 Go to next message
Hariharan Ramalingam is currently offline Hariharan Ramalingam
Messages: 7
Registered: May 2012
Junior Member
Received java.lang.ClassCastException: java.lang.NoClassDefFoundError exception in runtime when tried to run a Chart Report with crosstabs in BIRT 2.6.2. However the Exception Stack Trace is not getting printed at all.

The <param-name>BIRT_VIEWER_LOG_LEVEL</param-name> in BirtReports/WEB-INF is also to 'FINEST', but still no exception details printed. Error screenshot attached.

How can we get to the exception stack trace printed to identify the root cause?


Environment Details:

Websphere - 6.1.0.39
JDK - 1.5.0_28
Host OS - SunOS, v5.10
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #869545 is a reply to message #869542] Thu, 03 May 2012 14:57 Go to previous messageGo to next message
Hariharan Ramalingam is currently offline Hariharan Ramalingam
Messages: 7
Registered: May 2012
Junior Member
Moreover, there are no errors found in the BIRT Engine log in this regard

Thanks,
Hari
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #869681 is a reply to message #869545] Thu, 03 May 2012 17:13 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Does anything show up in the WS logs?

Jason


On 5/3/2012 10:57 AM, Hariharan Ramalingam wrote:
> Moreover, there are no errors found in the BIRT Engine log in this regard
>
> Thanks,
> Hari
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #869838 is a reply to message #869681] Fri, 04 May 2012 13:31 Go to previous messageGo to next message
Hariharan Ramalingam is currently offline Hariharan Ramalingam
Messages: 7
Registered: May 2012
Junior Member
Jason,

Websphere logs does not display any errors either.

The log has only the following.
[5/2/12 15:47:52:634 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [ViewerServlet]: Initialization successful.
[5/2/12 15:48:12:177 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/layout/FramesetFragment.jsp]: Initialization successful.
[5/2/12 15:48:12:259 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/control/ToolbarFragment.jsp]: Initialization successful.
[5/2/12 15:48:12:338 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/layout/ReportFragment.jsp]: Initialization successful.
[5/2/12 15:48:12:402 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/layout/SidebarFragment.jsp]: Initialization successful.
[5/2/12 15:48:12:495 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/dialog/DialogContainerFragment.jsp]: Initialization successful.
[5/2/12 15:48:12:574 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/dialog/SimpleExportDataDialogFragment.jsp]: Initialization successful.
[5/2/12 15:48:12:656 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/dialog/ExceptionDialogFragment.jsp]: Initialization successful.
[5/2/12 15:48:12:872 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/dialog/ParameterDialogFragment.jsp]: Initialization successful.
[5/2/12 15:48:13:261 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/parameter/HiddenParameterFragment.jsp]: Initialization successful.
[5/2/12 15:48:13:364 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/dialog/ExportReportDialogFragment.jsp]: Initialization successful.
[5/2/12 15:48:13:442 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/dialog/PrintReportDialogFragment.jsp]: Initialization successful.
[5/2/12 15:48:13:533 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/dialog/PrintReportServerDialogFragment.jsp]: Initialization successful.
[5/2/12 15:48:14:990 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/dialog/ConfirmationDialogFragment.jsp]: Initialization successful.
[5/2/12 15:48:15:078 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/layout/ReportContentFragment.jsp]: Initialization successful.
[5/2/12 15:48:15:175 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/control/NavigationbarFragment.jsp]: Initialization successful.
[5/2/12 15:48:15:273 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/layout/DocumentFragment.jsp]: Initialization successful.
[5/2/12 15:48:15:336 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/control/ProgressBarFragment.jsp]: Initialization successful.
[5/2/12 15:48:15:401 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/control/TocFragment.jsp]: Initialization successful.
[5/2/12 15:48:17:993 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [/webcontent/birt/pages/common/processing.jsp]: Initialization successful.

We have a custom adapter extending DataSourceEventAdapter and we have logging statements in beforeOpen method implementation. It doesn't seem to be invoking the beforeOpen method.

NOTE: Other Reports that has no charts in it works fine as expected
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #869883 is a reply to message #869838] Fri, 04 May 2012 15:49 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

The issue may be that the custom class is not being located or one of
the classes that it depends on.

Jason

On 5/4/2012 9:31 AM, Hariharan Ramalingam wrote:
> Jason,
>
> Websphere logs does not display any errors either.
> The log has only the following. [5/2/12 15:47:52:634 EDT] 00000055
> ServletWrappe I SRVE0242I: [Maistro] [/maistroReport] [ViewerServlet]:
> Initialization successful.
> [5/2/12 15:48:12:177 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport] [/webcontent/birt/pages/layout/FramesetFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:12:259 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport] [/webcontent/birt/pages/control/ToolbarFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:12:338 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport] [/webcontent/birt/pages/layout/ReportFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:12:402 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport] [/webcontent/birt/pages/layout/SidebarFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:12:495 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/dialog/DialogContainerFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:12:574 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/dialog/SimpleExportDataDialogFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:12:656 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/dialog/ExceptionDialogFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:12:872 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/dialog/ParameterDialogFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:13:261 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/parameter/HiddenParameterFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:13:364 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/dialog/ExportReportDialogFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:13:442 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/dialog/PrintReportDialogFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:13:533 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/dialog/PrintReportServerDialogFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:14:990 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/dialog/ConfirmationDialogFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:15:078 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/layout/ReportContentFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:15:175 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/control/NavigationbarFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:15:273 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport] [/webcontent/birt/pages/layout/DocumentFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:15:336 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport]
> [/webcontent/birt/pages/control/ProgressBarFragment.jsp]: Initialization
> successful.
> [5/2/12 15:48:15:401 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport] [/webcontent/birt/pages/control/TocFragment.jsp]:
> Initialization successful.
> [5/2/12 15:48:17:993 EDT] 00000055 ServletWrappe I SRVE0242I: [Maistro]
> [/maistroReport] [/webcontent/birt/pages/common/processing.jsp]:
> Initialization successful.
>
> We have a custom adapter extending DataSourceEventAdapter and we have
> logging statements in beforeOpen method implementation. It doesn't seem
> to be invoking the beforeOpen method.
> NOTE: Other Reports that has no charts in it works fine as expected
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #869922 is a reply to message #869883] Fri, 04 May 2012 20:02 Go to previous messageGo to next message
Hariharan Ramalingam is currently offline Hariharan Ramalingam
Messages: 7
Registered: May 2012
Junior Member
The same report runs successfully when the Chart section is removed.

Is there chance that we could have the complete Exception printed in the log?
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #870306 is a reply to message #869922] Mon, 07 May 2012 15:43 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

The stack trace should be showing up in the log. This looks like it may
be a bug. Do any reports with charts work?

Jason

On 5/4/2012 4:02 PM, Hariharan Ramalingam wrote:
> The same report runs successfully when the Chart section is removed.
>
> Is there chance that we could have the complete Exception printed in the
> log?
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #870567 is a reply to message #870306] Tue, 08 May 2012 18:59 Go to previous messageGo to next message
Hariharan Ramalingam is currently offline Hariharan Ramalingam
Messages: 7
Registered: May 2012
Junior Member
No, this is the first and the only report that has chart included. No exception stack trace found in the log with respect to this event.

Hari
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #870592 is a reply to message #870567] Tue, 08 May 2012 21:01 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you try the attached sample report?

Jason

On 5/8/2012 2:59 PM, Hariharan Ramalingam wrote:
> No, this is the first and the only report that has chart included. No
> exception stack trace found in the log with respect to this event.
> Hari
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #870782 is a reply to message #870592] Wed, 09 May 2012 16:11 Go to previous messageGo to next message
Hariharan Ramalingam is currently offline Hariharan Ramalingam
Messages: 7
Registered: May 2012
Junior Member
Tried running the sample Report, same result. Same exception encountered with no stack trace.
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #870836 is a reply to message #870782] Wed, 09 May 2012 19:23 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Do you think this is the same issue?
https://bugs.eclipse.org/bugs/show_bug.cgi?id=345738


Jason


On 5/9/2012 12:12 PM, Hariharan Ramalingam wrote:
> Tried running the sample Report, same result. Same exception encountered
> with no stack trace.
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #871289 is a reply to message #870836] Fri, 11 May 2012 18:56 Go to previous messageGo to next message
Hariharan Ramalingam is currently offline Hariharan Ramalingam
Messages: 7
Registered: May 2012
Junior Member
Environment seems to be the same when compared to the reported Bug #345738. Our development environment is Windows and test environment is UNIX with JDK version is 1.5. We are having problems only in the UNIX environment. We are not sure if our issue is exactly same, as we don't have the stack trace.

We tried running the report with log directory specified in the web.xml. Is there any other place where we need to specify the log directory and try ?

Also, we enabled class loader tracing to get a clue. There is an instance of classcastexception in the trace. The trace file is attached.
Please see if you would be able to suggest any solution based on the trace log.

Hari
Re: Unable to run Chart Report with CrossTabs using BIRT 2.6.2 [message #871686 is a reply to message #871289] Mon, 14 May 2012 17:15 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Hari,

Can you open a bugzilla entry for this and attaching that trace?

Jason

On 5/11/2012 2:56 PM, Hariharan Ramalingam wrote:
> Environment seems to be the same when compared to the reported Bug #345738. Our development environment is Windows and test environment is UNIX with JDK version is 1.5. We are having problems only in the UNIX environment. We are not sure if our issue is exactly same, as we don't have the stack trace.
>
> We tried running the report with log directory specified in the web.xml. Is there any other place where we need to specify the log directory and try ?
>
> Also, we enabled class loader tracing to get a clue. There is an instance of classcastexception in the trace. The trace file is attached.
> Please see if you would be able to suggest any solution based on the trace log.
>
> Hari
Previous Topic:How to display zero value
Next Topic:error no preview data with web service data source
Goto Forum:
  


Current Time: Sat Sep 20 20:11:37 GMT 2014

Powered by FUDForum. Page generated in 0.02736 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software