Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Warning on the problems view does not get cleaned - no .markers file exists
Warning on the problems view does not get cleaned - no .markers file exists [message #869284] Thu, 03 May 2012 07:15
Kohl Rabi is currently offline Kohl Rabi
Messages: 1
Registered: May 2012
Junior Member
Hi all!

I posted this on stackoverflow already, but noone seems to be able to help me, so I am trying it here.

I'm struggling with this for several hours already and cannot find a solution:

In Eclipse (using CDT) in the problems view I have the following warning:

"Invalid project path: Include path not found (/usr/local/boost_1_48_0)"

This warning does not go away, although the project compiles fine without any messages from the compiler or linker. It does not prevent me from working, but is more a cosmetical issue which I'd like to solve. It occurred after reinstalling Boost libraries (in a different location than they have been previously). Obviously, I changed the paths within Eclipse after reinstalling Boost, but somehow the old paths were not deleted from Eclipse. They are not accessible from the user interface either.

I tried the following already:

- deleting ${projectname}.sc file found under ${workspace}/.metadata/.plugins/org.eclipse.cdt.make.core as described in Comment 2 here: ht tps:// bugs.eclipse.org/ bugs/show_bug.cgi?id=206372 - this did not work this time (although on a seemingly similar problem that was the 'solution' at some earlier time)

- several posts (e.g. ht tp:// stackoverflow.com/ questions/3342240/how-to-know-the-path-where-the-errors-and-warnings-are-stored-in-eclipse ) suggest to delete .markers files in ".plugins/org.eclipse.core.resources/.projects/" - but for my project there simply are no such files --> maybe this is a hint to the source of the error

- I also tried to click on "clean project" and on "build configurations -> clean all" (from the menu when right-clicking on the project)

- tried to switch off "Automate discovery of paths and symbols" in "project-properties-> C/C++ Build -> Discovery options" and also clicked on the "Clear discovered entries now" button - both for C and C++ compilers - the warning disappears, but reappears after a few seconds

- right-clicked on project -> index -> rebuild

None of the above mentioned helped. Has anyone a suggestion what else I could try?

Thanks a lot!

Alex
Previous Topic:[Windows] application running on external cmd.exe command prompt
Next Topic:indigo cdt breakpoint problem
Goto Forum:
  


Current Time: Sat Oct 25 19:43:58 GMT 2014

Powered by FUDForum. Page generated in 0.01687 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software