Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » values of user properties are not being passed properly between report generation and report render
values of user properties are not being passed properly between report generation and report render [message #869023] Wed, 02 May 2012 17:33 Go to next message
Aleksey   is currently offline Aleksey
Messages: 42
Registered: April 2012
Member
Values of user properties are not being passed properly between report generation and report render when setting the property in onPageBreak() event.


If you run a very simple attached report below, then you see that if
1) you set the user-defined property in onCreate() event, then the property get correctly displayed at render (see onRender())
2) you set the user-defined property in onPageBreak() event that happens after onCreate(), then the property does not get displayed at render - the report output still displays the value set in onCreate().

Is that correct behavior?

generally, what is the purpose of onPageBreak() event? what can you do on this event? Looks like you cannot do any changes to element, correct? I tried to change the style (color etc) but it does not work - it returns an error. The same code works fine in onCreate()

I was looking to do some custom pagination using onPageBreak() event and setting element user properties to be later accessed at view time but it appears that is not allowed...

Thanks,
Aleksey
Re: values of user properties are not being passed properly between report generation and report ren [message #869675 is a reply to message #869023] Thu, 03 May 2012 12:38 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Aleksey

Have a look at this:
http://www.eclipse.org/birt/phoenix/project/notable2.5.php#jump_4

Note that it is possible for an onCreate event to be fired and the
report item to show up on the next page. The onPageBreak should fire
when it is placed on the page. For an example usage look at the
attached report that uses it to set a couple of page variables.

Jason

On 5/2/2012 5:33 PM, ivkina Mising name wrote:
> Values of user properties are not being passed properly between report generation and report render when setting the property in onPageBreak() event.
>
>
> If you run a very simple attached report below, then you see that if
> 1) you set the user-defined property in onCreate() event, then the property get correctly displayed at render (see onRender())
> 2) you set the user-defined property in onPageBreak() event that happens after onCreate(), then the property does not get displayed at render - the report output still displays the value set in onCreate().
>
> Is that correct behavior?
>
> generally, what is the purpose of onPageBreak() event? what can you do on this event? Looks like you cannot do any changes to element, correct? I tried to change the style (color etc) but it does not work - it returns an error. The same code works fine in onCreate()
>
> I was looking to do some custom pagination using onPageBreak() event and setting element user properties to be later accessed at view time but it appears that is not allowed...
>
> Thanks,
> Aleksey
>
Re: values of user properties are not being passed properly between report generation and report ren [message #870763 is a reply to message #869675] Wed, 09 May 2012 10:59 Go to previous messageGo to next message
Aleksey   is currently offline Aleksey
Messages: 42
Registered: April 2012
Member
Jason,
I understand that. Thanks. What I am saying though that it would be helpful if BIRT would allow to change User-Defined-Properties at control level onPageBreak event so you can later access these onRender.

You can still achieve the same thing by setting persistent vars or page vars at control -> onPageBreak() but it is a pain and less maintainable as opposed to keeping your scripting at one place at the control level

thanks,
Aleksey
Re: values of user properties are not being passed properly between report generation and report ren [message #870834 is a reply to message #870763] Wed, 09 May 2012 15:12 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

I agree. Do you mind opening a bugzilla for this?

Jason

On 5/9/2012 11:00 AM, ivkina Mising name wrote:
> Jason,
> I understand that. Thanks. What I am saying though that it would be
> helpful if BIRT would allow to change User-Defined-Properties at control
> level onPageBreak event so you can later access these onRender.
> You can still achieve the same thing by setting persistent vars or page
> vars at control -> onPageBreak() but it is a pain and less maintainable
> as opposed to keeping your scripting at one place at the control level
>
> thanks,
> Aleksey
Re: values of user properties are not being passed properly between report generation and report ren [message #871035 is a reply to message #870834] Thu, 10 May 2012 11:21 Go to previous message
Aleksey   is currently offline Aleksey
Messages: 42
Registered: April 2012
Member
#379146 has been logged

thanks!
Previous Topic:downgrading plugin to 3.7.1
Next Topic:Insert file into BIRT report
Goto Forum:
  


Current Time: Wed Jul 30 23:24:00 EDT 2014

Powered by FUDForum. Page generated in 0.01542 seconds