Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Trying to load UTP 1.1 (xmi from OMG)
Trying to load UTP 1.1 (xmi from OMG) [message #868821] Wed, 02 May 2012 15:36 Go to next message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
I am trying to generate an ecore file from the xmi provided here:

OMG org site, spec/UTP/1.1/ (xmi file, I cannot post urls)

in order to follow the complete standard performing transformations with QVT.

I am reciving an error, and even I can not see the content of the file with the "Sample Reflective Ecore Model Editor"


Errors:
* Package with uri ':// (omg site) /spec/XMI/2.1' not found.
* Class 'Documentation' is not found or is abstract.
* Package with uri ':/ (omg site) /spec/UML/20090901' not found.
* Class 'Profile' is not found or is abstract.


Has anyone tried that?

[Updated on: Wed, 02 May 2012 15:37]

Report message to a moderator

Re: Trying to load UTP 1.1 (xmi from OMG) [message #868837 is a reply to message #868821] Wed, 02 May 2012 15:58 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4097
Registered: July 2009
Senior Member
Hi

Please use the M2M (changing soon to MMT) newsgroup for model-to-model.

Your error messages are confused by changes that you may have been
forced to do as an early poster, but they look very like problems that
arise through inadequate UML registration.

Since your messages are inaccurate and your Eclipse version is
unspecified it's difficult to help further.

I would expect the Sample Reflective Ecore Model Editor to work, but
otherwise try the UML Model Editor.

Regards

Ed Willink

On 02/05/2012 16:36, Federico Toledo wrote:
> I am trying to generate an ecore file from the xmi provided here:
>
> Quote:
>> omg org site, spec/UTP/1.1/
>
>
> in order to follow the complete standard performing transformations
> with QVT.
>
> I am reciving an error, and even I can not see the content of the file
> with the "Sample Reflective Ecore Model Editor"
>
>
>
> Package with uri ':// (omg site) /spec/XMI/2.1' not found. Class
> 'Documentation' is not found or is abstract. Package with uri ':/ (omg
> site) /spec/UML/20090901' not found.
> Class 'Profile' is not found or is abstract.
>
>
> Has anyone tried that?
Re: Trying to load UTP 1.1 (xmi from OMG) [message #868841 is a reply to message #868837] Wed, 02 May 2012 16:09 Go to previous messageGo to next message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
I am using the last version of Eclipse (Indigo)


Could you try to load the file?

In order to try to load the model with the UML Model Editor as you suggested, I have changed the extension xmi to uml, and I could load it, but it is not what I expected, I mean: this is not being recognized as a UML Profile (see the attached img)

I can imagine that there is a problem with the definition of the xmi. According with its content, it seems to have been generated with MagicDraw. Do you know if there is any particular issue about the xmi generated with this tool.


What would you suggest me in order to work with the UML Testing Profile?
1.- use the standard implementation provided by OMG
2.- develop the profile from the scratch, with the UML 2 Tools or Papyrus
3.- ???


Thank you for your quickly response!
Re: Trying to load UTP 1.1 (xmi from OMG) [message #868869 is a reply to message #868841] Wed, 02 May 2012 16:45 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4097
Registered: July 2009
Senior Member
Hi

*.uml is only for UML using an Eclipse MDT/UML2 namespace.

*.xmi can be for OMG namespaces.

//http://www.////omg/./org///spec///UML///20090901// is the OMG UML 2.3
namespace which is not supported by Indigo.

Juno introduces UML 2.4 and 2.4.1 support and consequently many more
namespaces but not UML 2.3.
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=378281 raised.)

Try editing the XMI to use http://schema.omg.org/spec/UML/2.2.

Regards

Ed Willink

On 02/05/2012 17:09, Federico Toledo wrote:
> I am using the last version of Eclipse (Indigo)
>
>
> Could you try to load the file?
>
> In order to try to load the model with the UML Model Editor as you suggested, I have changed the extension xmi to uml, and I could load it, but it is not what I expected, I mean: this is not being recognized as a UML Profile (see the attached img)
>
> I can imagine that there is a problem with the definition of the xmi. According with its content, it seems to have been generated with MagicDraw. Do you know if there is any particular issue about the xmi generated with this tool.
>
>
> What would you suggest me in order to work with the UML Testing Profile?
> 1.- use the standard implementation provided by OMG
> 2.- develop the profile from the scratch, with the UML 2 Tools or Papyrus
> 3.- ???
>
>
> Thank you for your quickly response!
>
Re: Trying to load UTP 1.1 (xmi from OMG) [message #869396 is a reply to message #868869] Thu, 03 May 2012 10:42 Go to previous messageGo to next message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
I am not being able to do that, so it seems that I should create the UML testing profile for Eclipse from the scratch (I cannot believe that it has to be done by this way being a standard ... I feel like I am not understanding something....)

Thank you anyway!
Re: Trying to load UTP 1.1 (xmi from OMG) [message #869423 is a reply to message #869396] Thu, 03 May 2012 11:28 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4097
Registered: July 2009
Senior Member
Hi

I'm not clear what you are not able to do or why you cannot do what I
suggested. Editing takes one minute and might be error free, recreating
from scratch could take an hour or more before you start debugging
transcription errors.

Fundamentally you are using an unsupported standard; UML 2.3.

Regards

Ed Willink


On 03/05/2012 11:42, Federico Toledo wrote:
> I am not being able to do that, so it seems that I should create the
> UML testing profile for Eclipse from the scratch (I cannot believe
> that it has to be done by this way being a standard ... I feel like I
> am not understanding something....)
>
> Thank you anyway!
Re: Trying to load UTP 1.1 (xmi from OMG) [message #869460 is a reply to message #868869] Thu, 03 May 2012 12:40 Go to previous messageGo to next message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
the file in uml 2.3 is provided by omg ... I did not choose to use it Smile

I tried what you suggested but it did not work, or perhaps, I do not know how to do that ...

I've changed a couple of URIs references, ... what else should I do?


thank you so much!!
Re: Trying to load UTP 1.1 (xmi from OMG) [message #870272 is a reply to message #869460] Mon, 07 May 2012 14:31 Go to previous messageGo to next message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
I am attaching the xmi file provided by omg for the UTP. This is the file I would like to load and I couldn't.

Thank you if you have any clue or solution
  • Attachment: UTP_1.1.xmi
    (Size: 47.21KB, Downloaded 99 times)
Re: Trying to load UTP 1.1 (xmi from OMG) [message #870273 is a reply to message #870272] Mon, 07 May 2012 14:32 Go to previous messageGo to next message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
Also, they published an xsd (attached too) defining the profile
Re: Trying to load UTP 1.1 (xmi from OMG) [message #870285 is a reply to message #870272] Mon, 07 May 2012 14:56 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4097
Registered: July 2009
Senior Member
Hi

This is the same question as you asked 5 days ago.

Here is the same answer:

http://www.omg.org/spec/UML/20090901/ is the OMG UML 2.3 namespace which
is not supported by Indigo.

Juno introduces UML 2.4 and 2.4.1 support and consequently many more
namespaces but not UML 2.3.
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=378281 raised.)

Try editing the XMI to use http://schema.omg.org/spec/UML/2.2.

Regards

Ed Willink

On 07/05/2012 15:31, Federico Toledo wrote:
> I am attaching the xmi file provided by omg for the UTP. This is the file I would like to load and I couldn't.
>
> Thank you if you have any clue or solution
Re: Trying to load UTP 1.1 (xmi from OMG) [message #870287 is a reply to message #870285] Mon, 07 May 2012 15:03 Go to previous messageGo to next message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
well... I was trying to be more precise, because I couldn't solve the problem with this help you kindly gave me Crying or Very Sad

Anyway... thank you
Re: Trying to load UTP 1.1 (xmi from OMG) [message #870294 is a reply to message #870287] Mon, 07 May 2012 15:15 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4097
Registered: July 2009
Senior Member
On 07/05/2012 16:03, Federico Toledo wrote:
> well... I was trying to be more precise, because I couldn't solve the
> problem with this help you kindly gave me :cry:
> Anyway... thank you
As I wrote; UML 2.3 is not supported so you need to use either UML 2.2.1
with Indiigo or UML 2.4 with Juno.

To change UML versions you can edit the XMI file to change
http://www.omg.org/spec/UML/20090901 to
http://schema.omg.org/spec/UML/2.2 and it might work, provided the XMI
doesn't actually use any UML 2.3 facilities.

Regards

Ed Willink
Re: Trying to load UTP 1.1 (xmi from OMG) [message #870652 is a reply to message #870294] Wed, 09 May 2012 08:48 Go to previous message
Federico Toledo is currently offline Federico Toledo
Messages: 97
Registered: April 2012
Location: Ciudad Real, Spain
Member
Edward, now it is working!! thank you!

My problem was that in a previus try I changed the extension from xmi to uml, but as you said these namespaces are for omg standard, so the file must be an xmi, right?

thank you again!
Previous Topic:[Acceleo] How to run Acceleo from java file
Next Topic:[Acceleo 3 / MTL] Problems when wrapping java methods in MTL
Goto Forum:
  


Current Time: Fri Oct 24 08:42:22 GMT 2014

Powered by FUDForum. Page generated in 0.02815 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software